Analytics Reporting Error with Specific Browser, Instance of 2.36.4

We’re having an issue where within the front-facing Analytics Tables within Data Administration, when we select to run analytics (across all options), it reports an error. It also allows you to try again and start analytics (continuously).

Upon further testing: DHIS 2 Demo - Sierra Leone does not have this issue on same device. Also, on a different browser (using Microsoft Edge), there is also no issue. However in Chrome, on this particular instance, the issue persists.
image
Above is the Chrome Version I’m using.

See video below
Analytics Error

A pop up comes up that says “e.every is not a function”
The error message in the console for this is:

Refused to apply style from 'https://staging.vectorlinkcollect.org/dhis-web-data-administration/css/flexboxgrid.631.min.css' because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled.

Any thoughts here? It seems like something with my browser and by instance might be at fault. That said, I would have definitely thought that there would be a prevention (no matter what) of analytics running consecutively on top of one another.

1 Like

Thank you for sharing @Matthew_Boddie! It seems like there has been an issue related to this: Log in - DHIS 2 JIRA - you can see the latest update to this was 6days ago. I have asked for support and hopefully you’ll find the solution. Thanks! (:

1 Like

Hi @Matthew_Boddie! I think Gassim’s diagnosis is right, and I think that the fix for you will be pretty easy – since the issue only appears in Chrome, if you visit the app and perform a “hard reload”, it should fix the app in Chrome for you.

You can hard reload by using Cmd-Shift-R on Mac or Ctrl-Shift-R on other operating systems, or right-clicking on the reload button while the browser developer tools are open, which is how I got this screenshot:

The issue is caused by a stuck service worker that has cached an old version of the app that has that bug and is serving that old version of the app instead of the new one that you see in other browsers – it seems that the old version is only cached in Chrome for you. If that diagnosis is right, the hard reload which bypasses the service worker should fix it :slight_smile: Future versions of this app should be able to fix this on their own without needing a hard reload.

Hopefully this works for you – let us know how it goes!

2 Likes

Super cool! I didn’t know that we could do that! :smiley: Thanks! (:

1 Like

Very cool. Thanks both to @Gassim and @kpvandivier for the research and follow-up. I’ll test this out this afternoon EST (want to get through some data capture before we run analytics), and will definitely follow up

Update, This worked beautifully. Thanks again.

2 Likes