Data Entry Form Showing Strange Characters - DHIS2 2.36.9

Hi Community

We have DHIS2 2.36.9 running on our production server and one of our users has their Data Entry screen showing strange characters as shown in the screenshot below. Only one user has reported seeing gibberish on their Data Entry app, the rest are able to access the forms in a legible format with no problems. What could be the issue? I have tried logging in to the user account using a different laptop as well and it yields the same results.

Regards,
Cynthia

1 Like

Hi @ckambobe,

Did you try another browser [not just a different laptop]? Would you please check 1) the console and 2) the Network tab? Please try the Empty Cache and Hard Reload first:

Thanks!

I have tried the suggested solutions, nothing is changing. I have tried loading the page from Chrome and Firefox; clearing the cache; doing a hard reload and still the page looks the same.

This is what’s showing in the console

1 Like

Could you compare the user settings for the account that’s not working and the one that’s working? Are all settings the same?

Thanks!

1 Like

Hi @Gassim ,

That fixed the issue - the user had made changes to the default values. Thank you.

Regards,
Cynthia.

1 Like

Hi @ckambobe,
You’re welcome! If possible please share the values that messed it up to see if we can replicate this on play and figure out if there’s a bug.

Thank you!

Switching back to default fixes the issue

1 Like

Thanks @ckambobe! It seems this issue has been reported years ago about older versions (Log in - DHIS 2 JIRA)

The font appears squashed in the Data Entry app when selecting Myanmar style in user settings.

1 Like