No + button on dahsboard app

Hi all.

I am not able to create dashboards. No create button is shown. I am a user with a superuser privileges

What might be happening?


Hi @hernandezmachava,

This is interesting! What is the version of the DHIS2 instance that you are using? If you haven’t already, please try to clear the cache using the Browser Cache Cleaner app. If you are still facing the issue after clearing the cache (and it doesn’t work even if trying a different browser/profile) then please lets check if there are any error message.

From your browser, open the Network tab (F12 → Network tab) and visit the dashboard page then refresh the page. if you see any red text in the Network tab, click on it and take a screenshot. Additionally, if you see any errors in the Catalina.out log please share the log (without the sensitive info).

One last thing which might help to check: your_Instance_URL/api/me?fields=authorities, what authorities with the word dashboard do you see?


1 Like

Hi @Gassim,

I am using DHIS 2 version 2.36.6. Even a fter clearing the cache, I am still facing the issue. I don’t see nay red text in the network either.

These are the authorities I see with the word dashboard:

I am using Chrome as browser for DHIS 2, but If I try to use Microsoft edge, it works.

NB: All Apps except dashboard (I can not create any dashboards) work well in chrome.


Hi @hernandezmachava

Then this is a cache issue still. There are several things to do when cache won’t clear easily:

  1. Normally we run the Browser Cache Cleaner app but we might also need to run the Data Administration app → Maintenance → Clear application cache and the Reload apps options.

  2. Using Hard Reload and Empty Cache:

  1. Clear cache and storage from ‘Application’ in the
    Browser Developer Tools, see screenshot:

Hope it will work this time. Thanks! :pray:


Hi @Gassim,

Using Hard Reload and Empty Cache solved the problem.

Thanks you so much.

1 Like