Dhis-web-dashboard unreachable

Hi Support,

I’m currently hosting DHIS2 version 2,39.3.1 on my local machine port 8081. I can access the login page on localhost:8081 but after logging in I can’t reach http://localhost:8081/dhis/dhis-web-dashboard/ giving me the error
“This site can’t be reached
The webpage at http://localhost:8081/dhis/dhis-web-dashboard/ might be temporarily down or it may have moved permanently to a new web address.”

Please help me out I tried redeploying, clearing browser cache but still has the same error.

Hi @1c699b409a68f19fba95 Sakhile,

Is this a clean installation or an instance that has been previously used?

Are you able to access:
http://localhost:8081/dhis/api/resources OR http://localhost:8081/api/resources?

When you go to the login page, have you tried going using the Guest mode of your browser ( Browse Chrome as a guest - Computer - Google Chrome Help)?

Can you share the URL of the login page? if the login page is localhost:8081 then the dashboard URL would be localhost:8081/dhis-web-dashboard/ and not /dhis/dhis-web-dashboard…

I hope this helps

My login page URL is http://localhost:8081/dhis/dhis-web-commons/security/login.action which when I enter http://localhost:8081/dhis on the url box in the browser.

I’m able to access http://localhost:8081/dhis/api/resources

So I have just noticed that after logging in when I apply other urls for an example http://localhost:8081/dhis/dhis-web-tracker-capture/ I’m able to access them except for the http://localhost:8081/dhis/dhis-web-dashboard/

1 Like

Great, @1c699b409a68f19fba95 ! Thanks for the info. Could you please check that the user’s role has permission to access the dashboard app?

Thank it wasn’t select but I have selected it and saved but still doesn’t work

I’m a super user by the way.

You’re welcome. This could be a cache issue. Please try to login again using your browser’s Guest mode [ Browse Chrome as a guest - Computer - Google Chrome Help], if it works then clear your browser’s cache.


Thank you it’s working now.

1 Like

But it work on guest google chrome
account only

Yes, this means that this is a browser cache issue.

A post was split to a new topic: Blank page when creating/editing tracker programs