Event Data Entry Forms Not Opening in New Capture App

Hello. We have just recently updated to version 2.32 and we noticed that all our event program data entry forms do not load for data entry. We can access the Event Program and enter the event date but after that, the data entry forms do not load for data entry. The browser console also does not show any error messages.
The data entry forms can be accessed using the android app. We have tried to use different browsers but it is the same result. The event capture app has been removed as this app still worked for us.
I wonder if anybody else is experiencing this?
Your help with this would be most appreciated.
@dhis2-tracker

2 Likes

Hi @ifeanyiokoye,

I’m not entirely sure what causes the issue so please bear with me.

  1. What version did you use prior? 2.31?
  2. Could you verify that the android app has actually synced metadata after upgrade to 2.32?
  3. Could you verify that the form looks like this:
  4. Could you verify that a program you’re testing with has data elements listed in the maintenance app. Open maintenace app, select programs, click an event program, click assign data elements and then scroll to the bottom. Are the data elements listed here?
  5. Also in the maintenace app, in the create data entry form tab.
  • section: Make sure the section doesn’t only have an emtpy section listed. Like this:
  • custom: If you’re not using custom forms (if you’re not sure what I’m asking here, you probably aren’t), make sure the delete button isn’t visible. If it is and the custom form is empty (the box above), an empty custom form is used and we need to get rid of it.

Sorry about all the questions, I’m just making educated guesses here.

Joakim

2 Likes

Dear @Joakim,

  1. We were using 2.31.5 prior to the upgrade. We had the same issue in 2.31.5 but used the Event Capture app which was still available

  2. I can confirm that the metadata synced on the android app

  3. For the form, this is what we can see:


    and this:

  4. We have 2 Event Programs that currently have 2096 and 76 events respectively that were entered for these Programs using the old Event capture app. So, I can confirm to you that we have all those details:

Also, we can see the data entry form on the android app and enter data but we cannot figure out why the capture app does not load the data entry forms.

Your help with this is most appreciated.

Thank you

2 Likes

I also have the same issue. Everything was fine in 2.30. After upgreading to 2.31.6, event capture app still works fine but capture app doent show data elements of event programs except event date.
This is same even after upgrading to 2.32 and 2.33.

1 Like

Hi @ifeanyiokoye and @priyanga
Would you please update your DHIS2 versions builds to the latest builds.
I was unable to replicate the issue on the demo instances.

Let us know if this worked.
Cheers,
Emma.

1 Like

Thanks @Emma_Kassy. I am not sure this is an upgrade issue. Like @priyanga mentioned, they are currently on 2.33 and facing the same issue. From my discussion with some other folks, it appears other people are having this issue too.
The challenge is that there are no error messages to show what exactly is going on and the forms do not load with the new Capture app.
There appears to be a bug in the tracker and option sets in the latest patch of 2.32 and so will not be upgrading to that till it is fixed.
Anything we can do to try and investigate what is happening?

1 Like

Thanks @Emma_Kassy. I am using the latest build but the problem exists.
I also got the exact same issue as @ifeanyiokoye got. Same issue occurred with latest builds of 2.31, 2.32 and 2.33. In 2.31, Event capture works fine while Capture app does not load the data form in the same instance.
Following workaround worked for me to resolve this.

  1. Open the event program in edit mode.

  2. Go to “Create data entry form” > “CUSTOM”

  3. Select “Source”

Please note that in my case I am not using custom forms but a section form.

  1. Click on “Delete” (I cannot see any HTML code in the window. But still did this!. Once click on “Delete” it disappeared)

  2. “Save” the program.

After above steps my event programs are working well in the Capture app. (Done this with DHIS2 2.31.6)

@ifeanyiokoye, I would like to know whether this works for you too.

1 Like

Thanks @priyanga for the write up and confirming my suspicion.

The problem is that the program has been saved with form type “CUSTOM”. This was probably unintentional and due to a bug (for example the JIRA-issue mentioned below) or because it is too easy to make this mistake in the current UI. The old event capture app ran some additional checks to confirm the custom form type, the new capture app doesn’t yet (but these will be added).

We will improve upon both the maintenace app and the new capture app in this regard in the future.

Another (one step shorter) fix is:

  1. Open the event program in edit mode (in the maintenance app)
  2. Go to “Create data entry form” > “CUSTOM”
  3. Click the delete button
  4. And then the trick: DO NOT save the program, click cancel. If you click save the program will be saved with the form type “CUSTOM”, with no content. We do have JIRA-issue for this problem (https://jira.dhis2.org/browse/DHIS2-5801).

Remember to increase the program version for the capture app to download the new metadata

(or clear the cache on all the clients)

1 Like

@jomutsani
Since this is a re occurring issue and in different versions/builds it can be categorised as a bug.
Would please create a JIRA issue.

Thanks,
Emma

1 Like

Thanks a lot @Joakim for the clarification.

1 Like

HI @Emma_Kassy, the bug was already reported by @Joakim and @geetha is already working on it.

Thanks @priyanga for this solution. I followed @Joakim’s one step shorter procedure and my forms are loading now.
Thank you sirs. Really appreciate the help.

1 Like

This fix just saved me a few hours of database tinkering…:grinning::grinning::grinning:. I was now looking into the dataentryform database table to remove them.

2 Likes