Yarn start Error

Am getting this error when I try starting a web App in Windows 10.
What could have gone wrong?

Starting development server…
The app ui-library-task-template is now available on port 3000

throw er; // Unhandled ‘error’ event

Error: spawn yarn ENOENT

1 Like

Am using this:

Node.js v20.2.0

Hey @dmaritim,

I think it may be the node version. I suggest you try using v16.x or 14.x versions.


Right! And maybe yarn needs to be installed globally?

npm i -g yarn

Additionally, some other things to try:

  • delete your yarn file

  • in your app directory try d2 app scripts init .

  • run yarn before using yarn run start (also, sometimes yarn run start works while yarn start doesn’t, I haven’t spent time investigating why, but it does)

Hope these help! (:

Thank you @Gassim and @nnkogift for your contribution. Let me check these solutions out and get back with the result.

1 Like

@dmaritim were you able to resolve this? I am having the same error using Node v20.9.0 and running the app-platform. I tried to start the playground example app.

I have tried yarn run start.

Hi @jetisco4u

Since you are using version 20, I recommend following up on @nnkogift’s suggestion.

1 Like

I have other app that require at least Node 18 to work. Let me see if I can have a hack for it to work with Node 20 first.

1 Like