Program stages (timeline vs tabular) layouts in Tracker Capture

Hi! I am creating different program stages, sorted like this:


When I create a new patient on the tracker capture, if all the program stages have the same report date, they just disord like this:

They are ordered like, the last stage that appear is the latest updated. How can I put them in a static order?

Right, (please see Caroline’s post.) ~I think that they don’t appear out of order when the day is different but when in the same day, they come out of order as you said, so in your case since you need to make them all in one day then I think it’s a bug!~

Hi @aitor_garrido

We need to look in if this is a bug, but I will suggest a possible solution to you, to get the stages in a static order.

It is possible to change from Timeline Data Entry to Tabular data entry. The tabular data entry will automatically order your program stages as they are ordered in maintenance.

Follow these steps to change to tabular data entry:

  1. Open a TEI, look up at the top of the page to the right, you will see the icon with the gear as shown in the picture below. Select Show/hide widgets.

  2. Add the blue marking on Tabular data entry, and remove it from timeline data entry. Then close.

  3. You will now se the data entry has changed to tabular, and should be in the same order as in maintenance. The tabular is always static, regardless of which date you set on the different stages.

2 Likes

Thank you so much! as the way you said the stay stacit, so the problem is fixed!

2 Likes

Thanks @Caroline! (:

Hey folks,

Let me reopen this discussion, cause I am facing the same issue on order the Program Stages.

Details of my DHSI2 instance:
Version: 2.34.6, Build revision: ec64f0a, Build date: 2021-06-24 22:16

Picture of Program Stage Setup

Picture of the appearing on tracker app

1 Like

Hi @carlos.massavanhane,
Welcome to the community! :tada::tada::tada::tada:

I believe I can answer your question and I’d like to quote Markus above:

Another community member had the same issue recently but there’s a difference between the timeline and tabular sorting. If what you are looking for is static order then I think you could go for the tabular format. Here’s a nice explanation from @Caroline:

Thanks!

1 Like

Hey @Gassim, thanks a lot for your quick and very explicative reply to my question. I’ve successfully solved my issue with your tips. But I still have a question about the same subject, Can I fix this tabular display for all users?

1 Like

Hi @carlos.massavanhane,
Thank you, and thanks to @Caroline for the nice explanation too! :smiley:

Yes there are two steps described in the documentation:

Save the dashboard's layout as default

You can save the dashboard’s layout as default for a program.

  1. Open the Tracker Capture app.
  2. Open an existing TEI dashboard.
  3. Click the Settings icon, and select Save dashboard layout as default.
Lock dashboard's layout

If you are the administrator you have the option of locking the layout of the dashboard for all users.

  1. Open the Tracker Capture app.
  2. Open an existing TEI dashboard.
  3. Organize the widgets to the desired layout and save it as default (see section above).
  4. Click the Settings icon, and select Lock layout for all users.

Users will still be able to reorganize the widgets temporarily, but the layout will be reset to the admin’s saved layout after page refresh. The remove widget buttons will be hidden when the dashboard layout is locked.

Hope this helps!

2 Likes

Yes it helps @Gassim, thanks a lot for your assistance!
Have a great day!

1 Like