Problems with Report tables

Hi all,

I have a problem with totals using the report tables. In the picture DataEntry.jpg you can see a dataset with different DataElements and two categories combined between them. The dataset corresponds to the Organization Unit CS Pacu and the period time is the first week of 2012. When i try to make a report table of the same information, i get a report without totals (as you can see in the picture Report.jpg). The organization unit and the period time are the same. So any idea about why is it going wrong? I am using the 2.7 version.

Thank you very much!

image

image

Hi Jose,

Most likely there are no weekly values in your datamart (where all the reports fetch data from).

Weekly periods are not selected by default in the datamart scheduler.

Go to Maintenance->Data Administration->Scheduling and tick “Weekly” in the Aggregation period types section.

Also make sure to start the scheduler. The datamart will then export at midnight (server time).

Ola

···

Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Vetlandsvn. 95B, 0685 Oslo, Norway. Googlemaps link

On 1 June 2012 13:03, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi all,

I have a problem with totals using the report tables. In the picture DataEntry.jpg you can see a dataset with different DataElements and two categories combined between them. The dataset corresponds to the Organization Unit CS Pacu and the period time is the first week of 2012. When i try to make a report table of the same information, i get a report without totals (as you can see in the picture Report.jpg). The organization unit and the period time are the same. So any idea about why is it going wrong? I am using the 2.7 version.

Thank you very much!


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Yes, I didn’t run the Data Mart :slight_smile: and now it works! Thanks Ola, Jason.

One more thing: It seems that the period could not be weekly right? As it doesn’t appear in the Data Mart, and the same with the Scheduling task (no weekly checkbox appear).

Thanks.

···

On Fri, Jun 1, 2012 at 2:16 PM, Ola Hodne Titlestad olati@ifi.uio.no wrote:

Hi Jose,

Most likely there are no weekly values in your datamart (where all the reports fetch data from).

Weekly periods are not selected by default in the datamart scheduler.

Go to Maintenance->Data Administration->Scheduling and tick “Weekly” in the Aggregation period types section.

Also make sure to start the scheduler. The datamart will then export at midnight (server time).

Ola



Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Vetlandsvn. 95B, 0685 Oslo, Norway. Googlemaps link

On 1 June 2012 13:03, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi all,

I have a problem with totals using the report tables. In the picture DataEntry.jpg you can see a dataset with different DataElements and two categories combined between them. The dataset corresponds to the Organization Unit CS Pacu and the period time is the first week of 2012. When i try to make a report table of the same information, i get a report without totals (as you can see in the picture Report.jpg). The organization unit and the period time are the same. So any idea about why is it going wrong? I am using the 2.7 version.

Thank you very much!


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

I think weekly periods are in the latest 2.8 version but not 2.7.

Regards,

Jason

···

Sent from my mobile

On Jun 1, 2012 2:51 PM, “Jose Garcia Muñoz” josemp10@gmail.com wrote:

Yes, I didn’t run the Data Mart :slight_smile: and now it works! Thanks Ola, Jason.

One more thing: It seems that the period could not be weekly right? As it doesn’t appear in the Data Mart, and the same with the Scheduling task (no weekly checkbox appear).

Thanks.

On Fri, Jun 1, 2012 at 2:16 PM, Ola Hodne Titlestad olati@ifi.uio.no wrote:

Hi Jose,

Most likely there are no weekly values in your datamart (where all the reports fetch data from).

Weekly periods are not selected by default in the datamart scheduler.

Go to Maintenance->Data Administration->Scheduling and tick “Weekly” in the Aggregation period types section.

Also make sure to start the scheduler. The datamart will then export at midnight (server time).

Ola



Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Vetlandsvn. 95B, 0685 Oslo, Norway. Googlemaps link

On 1 June 2012 13:03, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi all,

I have a problem with totals using the report tables. In the picture DataEntry.jpg you can see a dataset with different DataElements and two categories combined between them. The dataset corresponds to the Organization Unit CS Pacu and the period time is the first week of 2012. When i try to make a report table of the same information, i get a report without totals (as you can see in the picture Report.jpg). The organization unit and the period time are the same. So any idea about why is it going wrong? I am using the 2.7 version.

Thank you very much!


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Yes weeks are in latest 2.8 stable, download from here:

http://dhis2.org/documentation

Lars

···

On Fri, Jun 1, 2012 at 6:40 PM, Jason Pickering <jason.p.pickering@gmail.com> wrote:

I think weekly periods are in the latest 2.8 version but not 2.7.

Regards,
Jason

--
Sent from my mobile

On Jun 1, 2012 2:51 PM, "Jose Garcia Muñoz" <josemp10@gmail.com> wrote:

Yes, I didn't run the Data Mart :slight_smile: and now it works! Thanks Ola, Jason.

One more thing: It seems that the period could not be weekly right? As it
doesn't appear in the Data Mart, and the same with the Scheduling task (no
weekly checkbox appear).

Thanks.

On Fri, Jun 1, 2012 at 2:16 PM, Ola Hodne Titlestad <olati@ifi.uio.no> >> wrote:

Hi Jose,

Most likely there are no weekly values in your datamart (where all the
reports fetch data from).

Weekly periods are not selected by default in the datamart scheduler.

Go to Maintenance->Data Administration->Scheduling and tick "Weekly" in
the Aggregation period types section.
Also make sure to start the scheduler. The datamart will then export at
midnight (server time).

Ola
--------

----------------------------------
Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Vetlandsvn. 95B, 0685 Oslo, Norway. Googlemaps link

On 1 June 2012 13:03, Jose Garcia Muñoz <josemp10@gmail.com> wrote:

Hi all,

I have a problem with totals using the report tables. In the picture
DataEntry.jpg you can see a dataset with different DataElements and two
categories combined between them. The dataset corresponds to the
Organization Unit CS Pacu and the period time is the first week of 2012.
When i try to make a report table of the same information, i get a report
without totals (as you can see in the picture Report.jpg). The organization
unit and the period time are the same. So any idea about why is it going
wrong? I am using the 2.7 version.

Thank you very much!

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp