Problem on installing DHIS2 on my laptop which has Ubuntu 18

Hello friends
I tried to install DHIS2 on my Ubuntu 18 machine but i’m getting an error also i followed some links like

1.[DHIS2: District Health Information System: DHIS2 Installation Guide for Ubuntu 16.04 LTS]
2.https://docs.dhis2.org/master/en/implementer/html/install_server_setup.html

But i’m facing very boring errors !
let me share everything

cataliana.out

Please any one to help
@ Julhas Sujan your help please

Thank you

Have you placed the WAR file in the folder? It seems it should be in /home/dhis/tomcat-dhis/ and I believe there you should see there a webapps folder and the WAR should be inside.

Yes it is inside webapps folder @jaime.bosque

Yes i have placed a war file inside the folder
/home/dhis/tomcat-dhis/

Ok, checking at the logs again … it seems that your user dhis is not being able to authenticate on postgres. Can you double check that you created the user properly and that it matches your dhis.conf (user / password)?

Okay let me start the installation again