Pivot Table does not display correct data

Hi All,

I have the following problem:

Data entered in the data entry module does not appear in the pivot table as a sequence of screens figure 1, Figure 2 and figure 3. Follow the example in the screenshot below with data entered in a unit hierarchically linked to Prog Maranhão in January 2014. Pivot Table data that month is not displayed. Have tried to update the analytical tables but did not work. Is running indefinitely.

Can someone help?

Thank you.

image

image

image

···


José Berilo
Estatístico
DEAVE - BEMFAM

jberilo@bemfam.org.br
Tel. 21 30052412

Hi José,

As you pointed out the missing data for January in your pivot table is most likely caused by a problem with the analytics tables generation.

In order to find out what went wrong with the analytics process we need to see your tomcat log.

The current analytics tables are only replaced when a new analytics export process has completed successfully, and if it fails the tables remain as before.

So that is likely why you can still see older data in your pivots, but not the new January data (you write that analytics process runs indefinitely).

Can you try to run analytics (manually from UI) one more time and then monitor your tomcat log at the same time, and possibly share the relevant part of the log with us?

Thanks.

Ola

···

Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 22 May 2014 18:32, José Berilo jberilo@bemfam.org.br wrote:

Hi All,


José Berilo
Estatístico

DEAVE - BEMFAM

jberilo@bemfam.org.br
Tel. 21 30052412

I have the following problem:

Data entered in the data entry module does not appear in the pivot table as a sequence of screens figure 1, Figure 2 and figure 3. Follow the example in the screenshot below with data entered in a unit hierarchically linked to Prog Maranhão in January 2014. Pivot Table data that month is not displayed. Have tried to update the analytical tables but did not work. Is running indefinitely.

Can someone help?

Thank you.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Hi Ola

I tried again to turn the tables manually analytics. The system remains locked and does not write error file in Apache Tomcat. Not sure what might be happening. A little time to migrate to postgres mysql base.

Thanks

···

2014-05-26 8:18 GMT-03:00 Ola Hodne Titlestad olati@ifi.uio.no:

Hi José,

As you pointed out the missing data for January in your pivot table is most likely caused by a problem with the analytics tables generation.

In order to find out what went wrong with the analytics process we need to see your tomcat log.

The current analytics tables are only replaced when a new analytics export process has completed successfully, and if it fails the tables remain as before.

So that is likely why you can still see older data in your pivots, but not the new January data (you write that analytics process runs indefinitely).

Can you try to run analytics (manually from UI) one more time and then monitor your tomcat log at the same time, and possibly share the relevant part of the log with us?

Thanks.

Ola



Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


José Berilo
jberilo@gmail.com
tel. 998060123


Ola Hodne Titlestad (Mr)
HISP
Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 22 May 2014 18:32, José Berilo jberilo@bemfam.org.br wrote:

Hi All,


José Berilo
Estatístico

DEAVE - BEMFAM

jberilo@bemfam.org.br
Tel. 21 30052412

I have the following problem:

Data entered in the data entry module does not appear in the pivot table as a sequence of screens figure 1, Figure 2 and figure 3. Follow the example in the screenshot below with data entered in a unit hierarchically linked to Prog Maranhão in January 2014. Pivot Table data that month is not displayed. Have tried to update the analytical tables but did not work. Is running indefinitely.

Can someone help?

Thank you.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Hi Ola and All

I’ve tried to do manually but the “Analytics” is running forever. Apparently he gets caught. The file “erro1” contains the log before entering the system. The file “erro2” contains the log after trying to generate the “Analytics”.

Could you help me?

Sorry but the system is not translating into English the screen.

Thanks.

erro2.log (55.2 KB)

erro1.log (8.99 KB)

···

2014-05-26 8:18 GMT-03:00 Ola Hodne Titlestad olati@ifi.uio.no:

Hi José,

As you pointed out the missing data for January in your pivot table is most likely caused by a problem with the analytics tables generation.

In order to find out what went wrong with the analytics process we need to see your tomcat log.

The current analytics tables are only replaced when a new analytics export process has completed successfully, and if it fails the tables remain as before.

So that is likely why you can still see older data in your pivots, but not the new January data (you write that analytics process runs indefinitely).

Can you try to run analytics (manually from UI) one more time and then monitor your tomcat log at the same time, and possibly share the relevant part of the log with us?

Thanks.

Ola



Ola Hodne Titlestad (Mr)
HISP

Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 22 May 2014 18:32, José Berilo jberilo@bemfam.org.br wrote:

Hi All,


José Berilo
Estatístico

DEAVE - BEMFAM

jberilo@bemfam.org.br
Tel. 21 30052412

I have the following problem:

Data entered in the data entry module does not appear in the pivot table as a sequence of screens figure 1, Figure 2 and figure 3. Follow the example in the screenshot below with data entered in a unit hierarchically linked to Prog Maranhão in January 2014. Pivot Table data that month is not displayed. Have tried to update the analytical tables but did not work. Is running indefinitely.

Can someone help?

Thank you.

Hi Jose,

you likely have an SQL view in your database which depends on the _orgunitstructure resource table which DHIS 2 needs to drop during re-generation. Please remove that SQL view and rather create it through DHIS 2 under data administration > SQL views - the system will then take care of dropping and recreating at appropriate times.

regards,

Lars

···

On Fri, Jun 6, 2014 at 2:40 PM, José Berilo Lima jberilo@gmail.com wrote:

Hi Ola and All

I’ve tried to do manually but the “Analytics” is running forever. Apparently he gets caught. The file “erro1” contains the log before entering the system. The file “erro2” contains the log after trying to generate the “Analytics”.

Could you help me?

Sorry but the system is not translating into English the screen.

Thanks.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

2014-05-26 8:18 GMT-03:00 Ola Hodne Titlestad olati@ifi.uio.no:

Hi José,

As you pointed out the missing data for January in your pivot table is most likely caused by a problem with the analytics tables generation.

In order to find out what went wrong with the analytics process we need to see your tomcat log.

The current analytics tables are only replaced when a new analytics export process has completed successfully, and if it fails the tables remain as before.

So that is likely why you can still see older data in your pivots, but not the new January data (you write that analytics process runs indefinitely).

Can you try to run analytics (manually from UI) one more time and then monitor your tomcat log at the same time, and possibly share the relevant part of the log with us?

Thanks.

Ola



Ola Hodne Titlestad (Mr)

HISP

Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 22 May 2014 18:32, José Berilo jberilo@bemfam.org.br wrote:

Hi All,


José Berilo
Estatístico

DEAVE - BEMFAM

jberilo@bemfam.org.br
Tel. 21 30052412

I have the following problem:

Data entered in the data entry module does not appear in the pivot table as a sequence of screens figure 1, Figure 2 and figure 3. Follow the example in the screenshot below with data entered in a unit hierarchically linked to Prog Maranhão in January 2014. Pivot Table data that month is not displayed. Have tried to update the analytical tables but did not work. Is running indefinitely.

Can someone help?

Thank you.

Ok Lars

I’ll make the change and check.

Thank you

···

2014-06-16 16:54 GMT-03:00 Lars Helge Øverland larshelge@gmail.com:

Hi Jose,

you likely have an SQL view in your database which depends on the _orgunitstructure resource table which DHIS 2 needs to drop during re-generation. Please remove that SQL view and rather create it through DHIS 2 under data administration > SQL views - the system will then take care of dropping and recreating at appropriate times.

regards,

Lars

não pode remover tabela _orgunitstructure porque outros objetos dependem dele


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp


José Berilo
Estatístico
DEAVE - BEMFAM
jberilo@bemfam.org.br

Tel. 21 30052412

On Fri, Jun 6, 2014 at 2:40 PM, José Berilo Lima jberilo@gmail.com wrote:

Hi Ola and All

I’ve tried to do manually but the “Analytics” is running forever. Apparently he gets caught. The file “erro1” contains the log before entering the system. The file “erro2” contains the log after trying to generate the “Analytics”.

Could you help me?

Sorry but the system is not translating into English the screen.

Thanks.


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

2014-05-26 8:18 GMT-03:00 Ola Hodne Titlestad olati@ifi.uio.no:

Hi José,

As you pointed out the missing data for January in your pivot table is most likely caused by a problem with the analytics tables generation.

In order to find out what went wrong with the analytics process we need to see your tomcat log.

The current analytics tables are only replaced when a new analytics export process has completed successfully, and if it fails the tables remain as before.

So that is likely why you can still see older data in your pivots, but not the new January data (you write that analytics process runs indefinitely).

Can you try to run analytics (manually from UI) one more time and then monitor your tomcat log at the same time, and possibly share the relevant part of the log with us?

Thanks.

Ola



Ola Hodne Titlestad (Mr)

HISP

Department of Informatics
University of Oslo

Mobile: +47 48069736
Home address: Eftasåsen 68, 0687 Oslo, Norway. Googlemaps link

On 22 May 2014 18:32, José Berilo jberilo@bemfam.org.br wrote:

Hi All,


José Berilo
Estatístico

DEAVE - BEMFAM

jberilo@bemfam.org.br
Tel. 21 30052412

I have the following problem:

Data entered in the data entry module does not appear in the pivot table as a sequence of screens figure 1, Figure 2 and figure 3. Follow the example in the screenshot below with data entered in a unit hierarchically linked to Prog Maranhão in January 2014. Pivot Table data that month is not displayed. Have tried to update the analytical tables but did not work. Is running indefinitely.

Can someone help?

Thank you.