OrgUnits unavailable on creation of tracker program

Hello community,
I am trying to capture granular information of students in implementation of dhis2, however when I create a program selecting org units is not possible as it is visible on picture shown here above, I can assure that orgUnits are created as you can see in the picture below
, this is affecting the whole process as it is even impossible to pick orgUnit in creation of a tracked entity type (student on my case) when you want to pick his/her location as it is seen in the picture below
can someone help me to solve this problem or advise accordingly


@Edward_Robinson would you please assist me on this, I know how you always help me in solving issues


Hey @Pacifique_Hategekima,

Did you try to use the DHIS 2 browser cache cleaner app? If it doesn’t work, maybe try to use the Data Administration app too:

In addition, please make sure the user has the proper authorities in the role settings and the user settings.

Finally, if all the above doesn’t work may you share the Network logs to see if we can find an error - please see screenshot below for the instructions. Also, if it’s possible share the tomcat log (without including sensitive info).

Hope this helps! (: Thanks!

I have had this issue before and one thing I forgot to do was to go into my own user profile as a superadmin and assign the top OU to myself.

1 Like

Thank you @Natalie_Tibbels and @Gassim for the responses given, I did all of you recommendations and it solve like 50% of the problem (this is very appreciated), I am now able to type the name of the OrgUnit and it comes though I am not able to seeing them unless I Typed them in search, any clue about this? thank you again

helped alot thank you

1 Like

Thanks! Always glad to help! Are you still not able to view the root OU and the rest of the OUs or was your problem solved? Please mark as solved if it is! (:

Thank you!

A post was split to a new topic: OU Hierarchy levels change in the Event Visualizer app