Maintenance module/application is not functioning

Hello community,

We have been facing an unusual error with our DHIS2 instance since last week 10-30. Until then all the admin/super users had been functioning normally. Suddenly the maintenance module’s menus/items ceased to display for admin users. Below, I’ve attached screenshots indicating the error, which presents a network error stating, “The namespace ‘maintenance’ was not found,” and additionally, “No row with the given identifier exists: [org.hisp. this.user.User#74581618]”.

Furthermore, the creation of a new user admin/super role in instance allows the module to work seamlessly.

Following are detail DHIS2 version we are using and looking for a response.

DHIS2 Version: 2.38.4

Build Version: 4119e92

Build Date:June 30, 2023 at 12:56

OS : Linux

OS architecture: amd64


@Gassim Looking for your support.


Hello @baktash.salehi

Did you try this with one user or different users?

1 Like

Hello Nnko,

All the admin users are showing same result.

1 Like


After investigation with trying different changes to the roles, finally resolved the admin user issue.
Our instance organisational hierarchy begins with MoPH > Cotenant > Country > Province > Region > District > and Health Facility. Initially, all administrative users were tagged at the Country level. The DHIS2 organization endpoint was encountering an error while opening the maintenance window. However, after reassigning the admin users to MoPH level and de-tagging them from the Country level the issue resolved.

We still don’t know why it starts behaving like this. Any suggestion @austin OR @Gassim.

1 Like

I was facing the same issue, tried the step you marked as solution but still getting the same error on maintenance. Any idea what could be the reason.
Thanks in advance

Hi @Pooja_Deshpande
It would be great if you could provide more details please. Thanks!

Hi @Gassim
Our instance was on version DHIS 2.40.3 and everything was working fine. I upgraded to the new patch since then maintenance app is coming as blank with maintenance end point ‘/api/40/userDataStore/maintainance’ failing giving 404 error
“httpStatus”: “Not Found”,
“httpStatusCode”: 404,
“status”: “ERROR”,
“message”: “Namespace not found: ‘maintenance’”,
“errorCode”: “E1005”

Also checked if the user is tagged to the highest hierarchy org unit and not tagged to any sub-org units as mentioned above.

It would be great if you can help me with this.
Thanks in advance.

Sorry for the problems here @Pooja_Deshpande.

Just a note: the non-presence of that user data store endpoint should not cause the maintenance app to fail. This data store stores customizations to display for the maintenance app. I have verified this on our test instance (Login app | DHIS2) by deleting the data store and reloading the app without issue.

If you see any other errors, please let us know.