Issue with updating Dataelement names through Postgress backend

Has anyone else had an issue with updating the dataelement table on the backend? I’ve cleaned up my data element names changing “# of” to “Nb of” and browsed the table in pgadmin and it looks fine. When I start DHIS-2 live, it initially displays the revised names, but as soon as I edit a data element it reverts the entire table back to the old version. I’ve deleted and recreated the resource tables and tried the operation 3 times. Any suggestions?

Randy Wilson

HMIS advisor

Rwanda MOH

You might should try clearing your browser cache and see if this helps.

Regards,
Jason

···

On Sun, Apr 10, 2011 at 8:55 AM, Wilson,Randy <rwilson@msh.org> wrote:

Has anyone else had an issue with updating the dataelement table on the
backend? I’ve cleaned up my data element names changing “# of” to “Nb of”
and browsed the table in pgadmin and it looks fine. When I start DHIS-2
live, it initially displays the revised names, but as soon as I edit a data
element it reverts the entire table back to the old version. I’ve deleted
and recreated the resource tables and tried the operation 3 times. Any
suggestions?

Randy Wilson

HMIS advisor

Rwanda MOH

_______________________________________________
Mailing list: DHIS 2 Users in Launchpad
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : DHIS 2 Users in Launchpad
More help : ListHelp - Launchpad Help

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

There is also a way to clear the DHIS/hibernate cache in Data Administration->Cache Statistics.

···

Ola Hodne Titlestad (Mr)
HISP
Department of Informatics

University of Oslo

Mobile: +47 48069736
Home address: Vetlandsvn. 95B, 0685 Oslo, Norway. Googlemaps link

On 10 April 2011 10:00, Jason Pickering jason.p.pickering@gmail.com wrote:

You might should try clearing your browser cache and see if this helps.

Regards,

Jason

On Sun, Apr 10, 2011 at 8:55 AM, Wilson,Randy rwilson@msh.org wrote:

Has anyone else had an issue with updating the dataelement table on the

backend? I’ve cleaned up my data element names changing “# of” to “Nb of”

and browsed the table in pgadmin and it looks fine. When I start DHIS-2

live, it initially displays the revised names, but as soon as I edit a data

element it reverts the entire table back to the old version. I’ve deleted

and recreated the resource tables and tried the operation 3 times. Any

suggestions?

Randy Wilson

HMIS advisor

Rwanda MOH


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Jason P. Pickering

email: jason.p.pickering@gmail.com

tel:+260974901293


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Thanks for the suggestion. I tried that as well... both the DHIS Cache and the Chrome browser cache. Neither seem to make any difference.

After initially listing the data elements correctly, the first time I edit any indicator I see the old names and the entire table reverts.

Randy

···

-----Original Message-----
From: Jason Pickering [mailto:jason.p.pickering@gmail.com]
Sent: Sunday, April 10, 2011 9:00 AM
To: Wilson,Randy
Cc: dhis2-users@lists.launchpad.net
Subject: Re: [Dhis2-users] Issue with updating Dataelement names through Postgress backend

You might should try clearing your browser cache and see if this helps.

Regards,
Jason

On Sun, Apr 10, 2011 at 8:55 AM, Wilson,Randy <rwilson@msh.org> wrote:

Has anyone else had an issue with updating the dataelement table on the
backend? I've cleaned up my data element names changing "# of" to "Nb of"
and browsed the table in pgadmin and it looks fine. When I start DHIS-2
live, it initially displays the revised names, but as soon as I edit a data
element it reverts the entire table back to the old version. I've deleted
and recreated the resource tables and tried the operation 3 times. Any
suggestions?

Randy Wilson

HMIS advisor

Rwanda MOH

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

Hi Randy,

Did you try a restart of the application itself?

Regards,
Jason

···

On Sun, Apr 10, 2011 at 9:17 AM, Wilson,Randy <rwilson@msh.org> wrote:

Thanks for the suggestion. I tried that as well... both the DHIS Cache and the Chrome browser cache. Neither seem to make any difference.

After initially listing the data elements correctly, the first time I edit any indicator I see the old names and the entire table reverts.

Randy

-----Original Message-----
From: Jason Pickering [mailto:jason.p.pickering@gmail.com]
Sent: Sunday, April 10, 2011 9:00 AM
To: Wilson,Randy
Cc: dhis2-users@lists.launchpad.net
Subject: Re: [Dhis2-users] Issue with updating Dataelement names through Postgress backend

You might should try clearing your browser cache and see if this helps.

Regards,
Jason

On Sun, Apr 10, 2011 at 8:55 AM, Wilson,Randy <rwilson@msh.org> wrote:

Has anyone else had an issue with updating the dataelement table on the
backend? I've cleaned up my data element names changing "# of" to "Nb of"
and browsed the table in pgadmin and it looks fine. When I start DHIS-2
live, it initially displays the revised names, but as soon as I edit a data
element it reverts the entire table back to the old version. I've deleted
and recreated the resource tables and tried the operation 3 times. Any
suggestions?

Randy Wilson

HMIS advisor

Rwanda MOH

_______________________________________________
Mailing list: DHIS 2 Users in Launchpad
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : DHIS 2 Users in Launchpad
More help : ListHelp - Launchpad Help

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

Ah, one more idea, as I have seen something like this happen before,
but not quite this serious.

Is there a proxy server between you and the application server?

Regards,
Jason

···

On Sun, Apr 10, 2011 at 9:22 AM, Jason Pickering <jason.p.pickering@gmail.com> wrote:

Hi Randy,

Did you try a restart of the application itself?

Regards,
Jason

On Sun, Apr 10, 2011 at 9:17 AM, Wilson,Randy <rwilson@msh.org> wrote:

Thanks for the suggestion. I tried that as well... both the DHIS Cache and the Chrome browser cache. Neither seem to make any difference.

After initially listing the data elements correctly, the first time I edit any indicator I see the old names and the entire table reverts.

Randy

-----Original Message-----
From: Jason Pickering [mailto:jason.p.pickering@gmail.com]
Sent: Sunday, April 10, 2011 9:00 AM
To: Wilson,Randy
Cc: dhis2-users@lists.launchpad.net
Subject: Re: [Dhis2-users] Issue with updating Dataelement names through Postgress backend

You might should try clearing your browser cache and see if this helps.

Regards,
Jason

On Sun, Apr 10, 2011 at 8:55 AM, Wilson,Randy <rwilson@msh.org> wrote:

Has anyone else had an issue with updating the dataelement table on the
backend? I've cleaned up my data element names changing "# of" to "Nb of"
and browsed the table in pgadmin and it looks fine. When I start DHIS-2
live, it initially displays the revised names, but as soon as I edit a data
element it reverts the entire table back to the old version. I've deleted
and recreated the resource tables and tried the operation 3 times. Any
suggestions?

Randy Wilson

HMIS advisor

Rwanda MOH

_______________________________________________
Mailing list: DHIS 2 Users in Launchpad
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : DHIS 2 Users in Launchpad
More help : ListHelp - Launchpad Help

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

Is this in your online server, Randy? I could take a look and see if I
get the same from here (Saigon).

And just a stray thought - but do people think there is any way this
could be related to sorting?

k

···

On Sun, Apr 10, 2011 at 9:26 AM, Jason Pickering <jason.p.pickering@gmail.com> wrote:

Ah, one more idea, as I have seen something like this happen before,
but not quite this serious.

Is there a proxy server between you and the application server?

Regards,
Jason

On Sun, Apr 10, 2011 at 9:22 AM, Jason Pickering > <jason.p.pickering@gmail.com> wrote:

Hi Randy,

Did you try a restart of the application itself?

Regards,
Jason

On Sun, Apr 10, 2011 at 9:17 AM, Wilson,Randy <rwilson@msh.org> wrote:

Thanks for the suggestion. I tried that as well... both the DHIS Cache and the Chrome browser cache. Neither seem to make any difference.

After initially listing the data elements correctly, the first time I edit any indicator I see the old names and the entire table reverts.

Randy

-----Original Message-----
From: Jason Pickering [mailto:jason.p.pickering@gmail.com]
Sent: Sunday, April 10, 2011 9:00 AM
To: Wilson,Randy
Cc: dhis2-users@lists.launchpad.net
Subject: Re: [Dhis2-users] Issue with updating Dataelement names through Postgress backend

You might should try clearing your browser cache and see if this helps.

Regards,
Jason

On Sun, Apr 10, 2011 at 8:55 AM, Wilson,Randy <rwilson@msh.org> wrote:

Has anyone else had an issue with updating the dataelement table on the
backend? I've cleaned up my data element names changing "# of" to "Nb of"
and browsed the table in pgadmin and it looks fine. When I start DHIS-2
live, it initially displays the revised names, but as soon as I edit a data
element it reverts the entire table back to the old version. I've deleted
and recreated the resource tables and tried the operation 3 times. Any
suggestions?

Randy Wilson

HMIS advisor

Rwanda MOH

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

--
Cheers,
Knut Staring

Hi Knut,

No... this is on my localserver instance. There is no proxy server in between. I've edited the hibernate file to comment out the autogenerate schema line... then I shut down and restarted dhis-2 live. That was weird. It reverted to an earlier version of the system without any of the data. Once I reenabled the autogenerate and restarted. I was back to my original data schema but with the old dataelement names.

I think I'm going to try and restore from an earlier backup. Lots of things are not working: for example when I try to export to DFX to move to MySQL - it doesn’t move any of the orgunits or datavalues. I've also downloaded the latest .jar file. Maybe my installation is damaged.

Randy

···

-----Original Message-----
From: Knut Staring [mailto:knutst@gmail.com]
Sent: Sunday, April 10, 2011 9:46 AM
To: Jason Pickering
Cc: Wilson,Randy; dhis2-users@lists.launchpad.net
Subject: Re: [Dhis2-users] Issue with updating Dataelement names through Postgress backend

Is this in your online server, Randy? I could take a look and see if I
get the same from here (Saigon).

And just a stray thought - but do people think there is any way this
could be related to sorting?

k

On Sun, Apr 10, 2011 at 9:26 AM, Jason Pickering <jason.p.pickering@gmail.com> wrote:

Ah, one more idea, as I have seen something like this happen before,
but not quite this serious.

Is there a proxy server between you and the application server?

Regards,
Jason

On Sun, Apr 10, 2011 at 9:22 AM, Jason Pickering > <jason.p.pickering@gmail.com> wrote:

Hi Randy,

Did you try a restart of the application itself?

Regards,
Jason

On Sun, Apr 10, 2011 at 9:17 AM, Wilson,Randy <rwilson@msh.org> wrote:

Thanks for the suggestion. I tried that as well... both the DHIS Cache and the Chrome browser cache. Neither seem to make any difference.

After initially listing the data elements correctly, the first time I edit any indicator I see the old names and the entire table reverts.

Randy

-----Original Message-----
From: Jason Pickering [mailto:jason.p.pickering@gmail.com]
Sent: Sunday, April 10, 2011 9:00 AM
To: Wilson,Randy
Cc: dhis2-users@lists.launchpad.net
Subject: Re: [Dhis2-users] Issue with updating Dataelement names through Postgress backend

You might should try clearing your browser cache and see if this helps.

Regards,
Jason

On Sun, Apr 10, 2011 at 8:55 AM, Wilson,Randy <rwilson@msh.org> wrote:

Has anyone else had an issue with updating the dataelement table on the
backend? I've cleaned up my data element names changing "# of" to "Nb of"
and browsed the table in pgadmin and it looks fine. When I start DHIS-2
live, it initially displays the revised names, but as soon as I edit a data
element it reverts the entire table back to the old version. I've deleted
and recreated the resource tables and tried the operation 3 times. Any
suggestions?

Randy Wilson

HMIS advisor

Rwanda MOH

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

--
Cheers,
Knut Staring

Randy,

It sounds like this is somehow related to your hibernate.properties
file. When the version without any data came up, could that be because
it was in fact using an H2 database?

I think the line you are referring to probably should not be commented
out, but it can take on different values:

When changing hibernate.properties, always check Help-> About DHIS2
after restart to ascertain that you are in fact looking at the
database you think you are (i.e. the same as you are looking at in
PgAdmin).

Knut

···

On Sun, Apr 10, 2011 at 10:03 AM, Wilson,Randy <rwilson@msh.org> wrote:

Hi Knut,

No... this is on my localserver instance. There is no proxy server in between. I've edited the hibernate file to comment out the autogenerate schema line... then I shut down and restarted dhis-2 live. That was weird. It reverted to an earlier version of the system without any of the data. Once I reenabled the autogenerate and restarted. I was back to my original data schema but with the old dataelement names.

I think I'm going to try and restore from an earlier backup. Lots of things are not working: for example when I try to export to DFX to move to MySQL - it doesn’t move any of the orgunits or datavalues. I've also downloaded the latest .jar file. Maybe my installation is damaged.

Randy

-----Original Message-----
From: Knut Staring [mailto:knutst@gmail.com]
Sent: Sunday, April 10, 2011 9:46 AM
To: Jason Pickering
Cc: Wilson,Randy; dhis2-users@lists.launchpad.net
Subject: Re: [Dhis2-users] Issue with updating Dataelement names through Postgress backend

Is this in your online server, Randy? I could take a look and see if I
get the same from here (Saigon).

And just a stray thought - but do people think there is any way this
could be related to sorting?

k

On Sun, Apr 10, 2011 at 9:26 AM, Jason Pickering > <jason.p.pickering@gmail.com> wrote:

Ah, one more idea, as I have seen something like this happen before,
but not quite this serious.

Is there a proxy server between you and the application server?

Regards,
Jason

On Sun, Apr 10, 2011 at 9:22 AM, Jason Pickering >> <jason.p.pickering@gmail.com> wrote:

Hi Randy,

Did you try a restart of the application itself?

Regards,
Jason

On Sun, Apr 10, 2011 at 9:17 AM, Wilson,Randy <rwilson@msh.org> wrote:

Thanks for the suggestion. I tried that as well... both the DHIS Cache and the Chrome browser cache. Neither seem to make any difference.

After initially listing the data elements correctly, the first time I edit any indicator I see the old names and the entire table reverts.

Randy

-----Original Message-----
From: Jason Pickering [mailto:jason.p.pickering@gmail.com]
Sent: Sunday, April 10, 2011 9:00 AM
To: Wilson,Randy
Cc: dhis2-users@lists.launchpad.net
Subject: Re: [Dhis2-users] Issue with updating Dataelement names through Postgress backend

You might should try clearing your browser cache and see if this helps.

Regards,
Jason

On Sun, Apr 10, 2011 at 8:55 AM, Wilson,Randy <rwilson@msh.org> wrote:

Has anyone else had an issue with updating the dataelement table on the
backend? I've cleaned up my data element names changing "# of" to "Nb of"
and browsed the table in pgadmin and it looks fine. When I start DHIS-2
live, it initially displays the revised names, but as soon as I edit a data
element it reverts the entire table back to the old version. I've deleted
and recreated the resource tables and tried the operation 3 times. Any
suggestions?

Randy Wilson

HMIS advisor

Rwanda MOH

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

--
Jason P. Pickering
email: jason.p.pickering@gmail.com
tel:+260974901293

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

--
Cheers,
Knut Staring

--
Cheers,
Knut Staring

I know facts ruin a good discussion but the problem here is the database translations:) You will have to update the corresponding value in the table called “translation” or simply truncate the table and restart the application.

Lars

Thanks Lars,

That did the trick! I truncated the translation table and the data loaded fine after a restart.

Mystery solved.

Randy Wilson

···

From: Lars Helge Øverland [mailto:larshelge@gmail.com]
Sent: Sunday, April 10, 2011 1:20 PM
To: Knut Staring
Cc: Wilson,Randy; dhis2-users@lists.launchpad.net
Subject: Re: [Dhis2-users] Issue with updating Dataelement names through Postgress backend

I know facts ruin a good discussion but the problem here is the database translations:) You will have to update the corresponding value in the table called “translation” or simply truncate the table and restart the application.

Lars