Instances stops working after adding organisation units

Hi @Sabri Thanks for your recommendation, yes i did different version installation of tomcat 9 and postgresql 14.1 and finally it worked, however now i am trying to add organization units and when i press “Save” it stops working , i mean the whole site stops working … i stopped tomcat and started it again and tried again after another login to my dhis2 account, still whatever i try to add stops the site from working and doesn’t save anything … i tried refreshing the website still nothing changed… so what do you think causes this site jam.???

1 Like

hi @Haliz.t f you can share the log to see where the error

1 Like

@Sabri

Also when i refresh the page

@Sabri These are my PC specifications

I am currently using
DHIS2 version 2.38
Java JDK 11
java version “18.0.2” 2022-07-19
Java™ SE Runtime Environment (build 18.0.2+9-61)
Java HotSpot™ 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing)
Postgresql 14.1
Tomcat 9

@Haliz.t please check again after clearing the cache. The best way to make sure it’s not a browser cache issue is by testing in a new/different browser/profile which you’ve not accessed the instance in. I almost always test using Guest and if the issue is not recurring in the Guest profile then I’m sure that it’s a browser cache issue.

If it’s still recurring please try to clear server cache from the Administration app → Maintenance → Clear cache and reload apps.

If both suggestions above don’t work then please check the Network requests by opening the Network tab in DevTools (F12 → Network) and then perform the action which causes the issue. If you then see any red text in the Network tab, select it and take screenshot. Please share that as well as the Catalina.out log (without the sensitive info).

Thank you!

Dear @Gassim Hello again! I hoe am not bothering you with all the troubles i have (i have already gave up on installing dhis2 on ubuntu) …
When i try to add the organization units everything stops working i even cannot logout of DHIS2 … so this is what you asked for and i hope you can assist me with much appreciation

Hi @Haliz.t,

I see the error above:
690x20

Please check you Java Heap space:
It might help to increase the java heap space to (-Xms4096m -Xmx4096m).
change to java.exe -Xms4096M -Xmx4096M¡± (source)

Dear @Gassim I have already tried this solution but unfortunately it didn’t help.
i started it with Xms7500m -Xmx7500m then i came down to 4096 then i finally set it on 1024 and still each time the same heap space issue comes up :frowning:

what to do now, please ??

@Haliz.t
Sorry to hear that, would you kindly share the Catalina.out log (without the sensitive info)? Maybe we’ll find a clue from the full stack trace of the root cause.

Thank you!

@Gassim so this is from today

Thanks @Haliz.t!

But for this issue we probably need to check the Catalina.out log. The log can be found in the folder: tomcat-dhis/logs/ and it will be a file catalina.out

Please open it using Notepad and copy everything except for the sensitive info (that includes password and username)

Thanks!

Try to assign memory from the tomcat options tab. That is the only way I was able to successfully run an instance of DHIS2 on my local computer (Windows 10). I hope this helps.

1 Like

@sanis @Gassim Hello and thanks for your help
Actually i changed the computer to another that has a 16GB RAM and apparently its working well…ONLY (as always) now i can move between all the categories of programs, data element, organization units with no problem, but when i try to go to another app such as Dashboards or Data Entry, the website doesn’t move at all and it doesn’t go anywhere it doesn’t even logout…
NOW what to do please ???