Error on complete

Hi DHIS2 community,

I have an error that pops up whenever I try to complete a program stage. I have tried trouble shooting to the point that I went through all my validation rules to see if I find it hidden somewhere in one of the program rules, but it yielded no results. I have a reason to believe the action rule is Error on complete because I have tried adding the same action rule and it gave double action on the error in tracker.

I have removed the mandatory fields from my attributes but it did not help. Also, I could not find positive results from inspection as it only shows Undefined and it is practically everywhere

Please assist. Thank you.

Hi @Tangy

What version of dhsi2 are you using? Is there a way to reproduce this issue in any of the instances?

Could you check if this fix (How to fix strange or incorrect icons in Maintenance) would solve the issue? And please make sure to clear the cache afterwards.

Using the Data Administration app → Maintenance, select Clear Application cache and Reload apps, and use the Browser Cache Cleaner app to clean the cahce. To ensure it’s not a cache issue, please test again using the Guest mode in your browser.


Hi @Gassim
I am using version 2.37.8.

I have cleared my cache countless times using both the browser cache cleaner and data administration but I still see the error.

Also, I have used version 2.37 of the demo and I have created the same error in the
WHO RMNCH Tracker program.
I then went to register a new client to see if the error is triggering, it triggered and below is the error message

However, something strange happened when I went back to the program rules to screenshot it with the intention of sharing it here; I could not find the program rule, which I have named ‘error_on_complete’. I’ve created it on the firstname variable and the rule is (fristname != true) with action (error on complete) and Expression to evaluate and (assign ‘’).

And someone just fixed the error. Because it is not showing anymore which I think beats the purpose because I didn’t get to find out how it was resolved.

So I got tempted to create one again and screenshot the process.
The error:



Error on tracker: When first name has no value

The error does not show when I have deleted the program rule, which is good. My challenge is I cannot find the error from end, I would say the same way I could not find it the first time I created it on the demo version.