Encounter a problem in Installing Standard Apps from App Store

Dear friends,

I tried to install an app (WHO Metadata Browser) from app Store, but the app is not installing and it give me a message Like (failed to install an app from the app store, could not rename file).

My DHIS2 version is 2.32.4

Please advice me how resolve this problem.


Dear @Ibrahimi

Sorry to see you are having challenges with installation of of this App, copying in @stephocay and @omielp to give you more guidance.


Hi, @Ibrahimi,

This is normally an issue with the sever configurations realated to one of the followings:-

  • write permission to the apps directory
  • a settings within nginx settings. If using the old configuration, you might need to remove the static files sections where you see css, js, etc.


Thank you Mr. Prosper

Thank you Stephen, I will try it.

Hi @Ibrahimi,

Did @stephocay’s suggestions help?


Dear Karoline,

Appreciates your follow up. Actually, I am not expert in server configuration, so couldn’t follow the advice, the one who installed the software for us and configure the server, is not accessible due to COVID19, So I will keep try.



Hi Stephen,
Facing a similar problem, I have a local installation running on the following:

  • DHIS2 v2.34.0
  • Apache Tomcat/9.0.36
  • 1.8.0_251-b08
  • Windows Server 2016

Any solution for a windows environment

Got sorted, something to do with windows permission.
I gave Sharing/NTFS permission to the SharingSettings folder (C:\DHIS2\files\apps\SharingSetting)

The app installs but fails to rename the property files, solution

  1. Go to DHIS2_HOME folder
  2. Locate the SharingSetting folder and right click, and select properties
  3. Go to the user running Tomcat server
  4. Give him write permission

NB. Care to be taken not to give Full control


Thank you Tiha, It worked perfectly.