Can't export data

Dear DHIS2 team,
I am working on doing analysis/extract data set /from DHIS2 system version 2.29 but when I event export the data no data can extracted and 0MB but thier is data that collected can generate report using pivot tabel and event report and also I would like to change platform to local disk from cloud ,How can I change ?

Thanks for your usual support ,

1 Like

Hi @Betelhem_simachew,

Please try to clear the cache as well as run the tables analytics export. Are you seeing any errors in the Catalina.out log? I believe it’s also recommended to update your instance rather than 2.29?

HI Al-Gassim,
Thanks for your support but I run table analytics and clean cache but no change on the output and no eror .is thier any way to do analysis ?


Thank you @Betelhem_simachew! We’d need more info to know why this is happening. Would you please share the Catalina.out log (without the sensitive info)? Also please check in the Network tab (F12 > Network) if there are any errors.

Hi Gassim,
I did run analytics table and their is no change on the output ,there is no any error in the catalina outlook


I run analytic

1 Like

Okay thanks @Betelhem_simachew! So you can retrieve the data using Data Visualizer app and the Event Reports app, but you can’t export the data.

May I ask you to provide the steps you are using to export the data? It might have been a bug in 2.29 where the downloaded file was 0MB like you mentioned but 2.29 is no longer supported.

Yes please share the steps you are following to do this. To know if we have other options, maybe reproduce this on an instance or see if there’s a reported bug for that version (and if there’s a workaround)


A post was split to a new topic: Network error, unable to select OUs for export

@Betelhem_simachew I’ve had issues with exporting metadata in CSV format through import/export app and also through the api endpoint. If you’ve somehow found anway around this, I would very much appreciated if you can share updates.

Although I should also add that it’s only on a particular instance (2.38) that I sometimes have this issue and when this happens I’m able to export in json format just not csv.

1 Like

A post was merged into an existing topic: Network error, unable to select OUs for export

I followed the following step ,I went to the app menu and selected export import then select event report then select the organization unit and program then select export button .

Those are what I follow the steps kassim


1 Like

@Betelhem_simachew I’m sorry I’m not able to reproduce this issue on any of the latest and supported dhis2 versions. I tried to reproduce this on 2.35 but I’m still able to download in all formats.