Browser Cache Cleaner stuck on loading ... or not clearing caches

Hello community,

There’s a kind of misbehavior in the Browser Cache Cleaner app in DHIS2 2.35 the DHIS2 version that I’m currently using. When you open the app, at some point it give a lugging screening with endless loading …

or some other time, it loads and doesn’t clear cache, so that you can proceed.

Let me know if anyone has ever had the same issue or for the development team to advise how to proceed is such scenarios.


Hi @Josue,
Thank you for writing to the community. I tried to use the Browser Cache Cleaner app in using the version 2.35.8 and it’s working fine, but which release are you using? Is it .8 as well?

Did you try selecting one by one to see if only one of the selected items is casing an issue? Or is it causing issues regardless of which one is selected? Secondly, after attempting to clear the cache, do you see any error in the Network tab, Console, or Catalina log?

Thank you!

Hi @Josue

When this happens, do you have multiple tabs open in your browser with the same DHIS2 session?


1 Like

Hi @Gassim
Thank you for sharing your experience too.

Normally, it works fine and these discrepancies were occasionally occurring. I am using DHIS2 2.25.4

In the console tab, I could see that the caches are successfully cleared but no changes reflected on the UI.

And I realized, that it mostly happens when many DHIS2 tabs are opened in the same browser window. Not sure about the exact reason.


1 Like

Hi @Caroline
Actually, this was/is the situation.

Best regards,

1 Like

I have 1 tab open and I tried to clear my browser cache and it did not respond. I closed the browser completely and opened a fresh instance (usually in incognito mode) and this is still persisting and org units are not loading in Tracker Capture and Data Entry modules.

We are using

Also to note that the browser cache cleaner app used to work even with multiple tabs open in the past. Not sure what has changed.

Please try again using the Data Administration tab → Maintenance page, Clear application cache and Reload apps. Then open in Incognito mode (it’s even better if you open in Guest mode!)

Cache is sometimes very sticky :sleepy: Some times it needs more work: