App not responding error pop-up in Android App


We are checking the visualisations in the Android App. In this process we tried adding visualisations/ adding data to visualisations. But most of the times we see ‘App is not responding’ pop-up. Also we see different stack trace errors most of the times. Sometimes after re-installing or removing some visualisations, it is working. May I know the reasons and how can we avoid them?

Thank you!

Hi @Katta_Nityapriya

Sorry to hear that you are having issues with using the app on your mobile phone, what type of phones are you using? Please check that the mobile device specifications are met (Mobile device specifications - DHIS2 Documentation).

This is a common error in Android OS when there are issues with the memory in the device. It might help to clear the cache of unused apps and then restart the phone. The issue seems completely because of device memory and settings so the solution depends on usage, device, configurations…etc

If you’d like to dig more into understanding the issue and sharing details that will help understanding the issue, you could have a look here: Android Troubleshooting (technical guide) but ultimately this seems like it’s an issue from the device itself, did you try different mobile devices?

I hope this helps. Looking forward to hear more.

Thank you @Gassim for the clarification.
Yes, I have checked the device specifications and everything is met.
Also we have tried running the application in our mobile devices and using Android studio as well.

1 Like

Thanks! Please see the troubleshooting guide linked above and see what type of error logs you could share because to understand the issue and what’s going on more debugging and information is required.

Hi Katta!

Could you provide some screenshots of the problem? Particularly the Logs you’re getting pointing to the class where the exception is thrown, that could be of great help.
Feel free to add any extra info you think might be relevant, the more the better.

Thank you

1 Like

This is one of the error.

We observed that the above error is showing in 2.8.2 version for the user with no access and no access for the data element message in version.We are assuming that this is the part of upgrade. Can you please confirm it, if it is the excepted?

Could you please explain further? So in version 2.8.2 the user didn’t have access and no error appeared but after the upgrade the same user who still doesn’t have access is now seeing an error?


In version it was showing error like this:

And in 2.8.2 it is showing the error like this:

Are they both showing the error for same reason? Is it a part of the upgrade?

They both seem because to be related to sharing access to a data element that the user doesn’t have access to. It might help to clear the app cache and delete data in the phone and then sync again but make sure that the user has the proper sharing settings configured for the data that is going to be synced.