What am I missing: The new "Capture" apps on 2.38 loads forever

I am testing the new Capture apps by using 2.38.1. However, when I open the Capture app is just loading. This is only happening when I open a tracker program. Steps

  1. Open “Tracker” App
  2. Open a tracker program for the first time
  3. Click on “Opt in for my program”
  4. Create "new’ for a new enrollment
  5. It Keep loading forever

Any tip will be appreciated.

Console message

Capture error2

Loading image

Hi @sele,

Try to add the key manually by going to the Datastore Management app and then click on New:

I remember we had created a jira bug issue for this but can’t recall which so would you like to create an issue for this topic at jira.dhis2.org:slight_smile:

Thank you! :slight_smile:

Dear @Gassim , thanks for your response and your inputs. Matter of fact, it doesn’t work even after creating a key manually. I will go ahead and create a Jira topic for this.

However, if there is anyone out there, who managed to use a new Capture Apps, I would appreciate to hear their experience.

1 Like

I have created Jira issue

https://jira.dhis2.org/browse/DHIS2-13500

Thank you @sele! Thanks for setting up a test instance as well. :slight_smile:

Adding the keys manually removed the errors:

I tried uninstalling the app and then installing again, tried clearing cache, and checked the program settings. Nothing worked yet.

However, it seems not to solve the problem so maybe there’s another error. Do you see any errors in the Catalina.out log? If you do please share the log (without the sensitive info).

Thanks!

@Gassim , Unfortunately the Catalina.out doesn’t pop-up any message. It is static with no any message when you perform the above task.

Any other input will be appreciated

Hi @sele,
I’ve triaged this issue (@tracker-backend) and hopefully we’ll get a response soon.

Thanks!

Thanks @Gassim

1 Like

I have had this issue too, can you check whether it works in incognito or not?
My issue was that I had an adblock extension activated. If it works in incognito then that could be the issue.

Best regards,
Karoline

1 Like

Hi @Karoline , thanks

  1. It doesn’t work even with the Incognito page
  2. Using the same computer and same browser I can open the new Capture at the Demo site. (DHIS 2 Demo - Sierra Leone)
  3. Initially, I thought it could be my configuration with other databases. I decided to create a new database with few Attribute and Data elements. But also I doesn’t work. You can access the test database here

http://212.71.232.54/2381 login credentials admin/district

  1. I tried to Upgrade the Capture version to the one released today (100.11.4) but still not working

@Simona.Domnisoru added a comment to the JIRA issue:
"Hey,

The bug is reproducible for an organization unit without a code. The bug is present both when enrolling a new TEI and editing the TEI profile.

The workaround, while the bug is fixed, is to add a code to the organization unit."

3 Likes

Thanks @Karoline , this is a solution for now. It has fixed my problem

1 Like