VPS Issue, DHIS2 instance turns unavailable to work on it

Hi all,

I want to know if somebody in this community had/have a similar issue.

We are working with a DHIS2 instance hosted in a VPS.

It’s the second time we have an issue where we are working normally, suddenly, the instance is unable. We run htop and we got the attached message.

The first time we started the VPS (Formatting, OS reinstallation) and the issue was solved, however, now we have the issue again.

Please let us know if this issue is familiar for you and the solution you implemented.

Cheers!

According to your htop screenshot it seems that DHIS2 (Tomcat) is not running. I might be wrong as the output is trimmed but I don’t see a process of Java / Tomcat running.

Have you followed any specific guide to install it? Maybe you have not enable Tomcat as a service? Or have you forgotten to launch it manually?

Please check this:
https://docs.dhis2.org/en/manage/performing-system-administration/dhis-core-version-235/installation.html#install_java_installation

1 Like

Hi Jaime!

Actually, last friday, I restarted the VPS and the issue was solved (For the moment, all is working normally). However, I am very intrigated…Is a DHIS2 instance in 2.34 RAM high performance?

I followed the installation guide listed in dhis.org to 2.34, but I will check the mentioned link (Installation - DHIS2 Documentation).

Thx for your feedback.

HI @carmihersie1 .

Not really sure what do you mean by your question. DHIS2 will perform very differently depending on the size of your database, and even then, it depends on the number of TEI or Datasets.