Values in API but they don’t seem to appear in pivot tables at all

Hi there,

I’m facing the same issue in the latest CI build of 2.31dev, I have text value data elements for which I can see the values from the API but they don’t seem to appear in pivot tables at all (even though analytics have run and the numeric values display).

Has this fix been put in 2.31 and 2.30 as well?

Thanks,

  • Jasper
1 Like

Hi Jasper,
I tried testing this on the Play servers for v2.29 & v2.30 & cannot view the entered ‘Comments’ data in the Pivot Table app (& even when exporting as .xls) - details below on what I did to test it (I entered data for the 3 qtrly periods for 2018):

  • Data Element: Project: Comments
  • Data Set: Project Management
  • OrgUnit: Badjia

Maybe other people have tried to test this with other results?

1 Like

I see from the JIRA issue here that this issue was fixed in 2.29.

@jan can you comment on whether the fix was put into 2.30 and 2.31 as well? It appears we’re facing the same problem - text values won’t appear in pivot tables.

1 Like

As the previous JIRA issue was closed I opened another: https://jira.dhis2.org/browse/DHIS2-5854

It would be great to get a developer response to this.

1 Like

Hi @Jasper_Timm,

Our core team will have a look at this and revert soonest.

Best,
James.