User Setting Page Not Opened in Linux Ubuntu 20 (DHIS2 37.7-Version)

My Application works properly but my User Profile is not Opening it gives as below error

An error occurred in the DHIS2 application.
The following information may be requested by technical support.

Thank you for your post @mohammadayub864 and welcome to the community!

What is the version of the dhis2 instance that you are using? Could you check what error is displayed in the Network tab (F12) in your browser’s developer tools?

Before you click on the link ‘edit profile’ open the Network tab so only relevant requests will be displayed. If you find red text please take a screenshot, thanks!

Thank you so much for the reply , it is version 37.7 it does not display any red message. in Windows locally hosted it is working but in Linux Server Ubuntu 20 other pages are working only Profile Module

You’re welcome! :slight_smile:

Thank you for taking the screenshot! It doesn’t show any network error so maybe you need to clear the cache first. Please try to use the Browser Cache Cleaner app and try again.

Feel free to post back to the community how it goes, thanks!

I did many times Browser Cache Cleaner and Cleaned Browser Histories but it still gives this issue Any Other Solution Please ?

I changed configuration and dhis2 war version now I received Message Http Not Found, I also changed my ubuntu from 20 to 18 as recommended in documentation Please let me know which war version is best for ubuntu 18.4 PostgreSQL 10

Thank you in advance

Dear AL-Gassim Sharaf Addin,

I have an issue now

Please support us.

Thank you in advance
Mohammad Ayub Yousafzai

Dear AL-Gassim Sharaf Addin,
I solved this issue by removing the ROOT Folder and Stop PostgreSQL Database Service , Tomcat Service and clean the log files that is created.
then restart the services.

Mohammad Ayub Yousafzai


Thank you for sharing the solution! I’m glad it worked.:+1: