Use of Short name in Data visualizer instead full name

I have created some data visualizations ( Bar graphs, Stacked graphs), and all these visualizations show data element names. I have assigned a short name to the data elements as well. Now I want my visualizations to show short names instead of full name.

Can we achieve this in dhis2?

If there is any way please guide.

Hi Tooba,

Yes, but I don’t think it’s possible to do it for just one visualisation or dashboard - you need to make this change across all analytics.

It also differs depending on whether you want to do it for just your own user, or for the whole system (which will affect all users with the “default” setting).

To change just your own user, go to your user drop-down (the circle with initials in the top-right of the screen), select “Settings”, choose the tab “User settings” and change “Property to display in analysis modules” from “Name” to “Short name”.

To change the default for all users, you will need to have admin permissions: go to the DHIS2 “System Settings” module/app, choose the Analytics tab, and change “Property to display in analysis modules” from “Name” to “Short name”.

Important: this second system-wide change will only affect users whose own user settings still have “Use system default” as the option chosen for “Property to display in analysis modules”. If a user has already changed their specific account to be “Name” or “Short name”, then this user setting will override your new system-wide setting.

Note also that these changes will take effect immediately (there’s no need to regenerate the analytics). So I would advise doing any system-wide changes overnight, so as not to confuse users who might be in the middle of using the analytics. :wink:

Cheers, Sam.


I have done this, though in the visualizer it started sowing the short name when I import the same graph on the dashboards , its started showing the full name on the graphs. But in the visualizer its showing the short name.

Now how we resolve this , as I also need to show on the dashboards and it should show the short names.

Hi Tooba,

I’m wondering if (as always with DHIS2!) it might be a cache problem? If you’ve already viewed that dashboard, you might be looking at a cached version of the chart…

Perhaps try clearing the cache, and if that doesn’t work, try making and saving a small change to the visualisation, and see if that refreshes the chart on the dashboard.

Cheers, Sam.

1 Like

Hi Tooba,

To help others that might have the same issue, have you been able to resolve this issue? (Was the problem just caching, or something more complex?)

Cheers, Sam.