Upgrading from 2.5 to 2.20 using dhis-live

Dear All,
I am trying to upgrade one of our local (standalone server) instances
of dhis2 which was running on version 2.5. I exported the database and
import the database into a dhis2-live version 2.20.
The application is running on windows and my database is PostgreSQL
9.3.9. The upgrade was successful but when i ran "Data Set Report" for
a particular Data Set; i am getting a blank report.

I tried to do "Analytic and Data Mart" but i am getting error. Please
find the attached log files.

Please can someone help?

dhis.log (211 KB)

dhis-analytics-table.log (5.92 KB)

···

--
Regards,

Gerald

Dear Thomas,

2.5 is a very old version. There has been many changes till 2.20.

I would suggest that you do a systematic upgrade 2.5 to 2.6 to 2.7 to 2.8…2.20.

It is a simple process you need to stop the tomcat server, then dump the war file and start the server again for each version.for version 2.13 to 2.20.you may need to run upgrade scripts before dumping the war file.

You can get war files from https://apps.dhis2.org/ci

Good luck.

Alex

···

On Friday, September 25, 2015, gerald thomas gerald17006@gmail.com wrote:

Dear All,

I am trying to upgrade one of our local (standalone server) instances

of dhis2 which was running on version 2.5. I exported the database and

import the database into a dhis2-live version 2.20.

The application is running on windows and my database is PostgreSQL

9.3.9. The upgrade was successful but when i ran “Data Set Report” for

a particular Data Set; i am getting a blank report.

I tried to do “Analytic and Data Mart” but i am getting error. Please

find the attached log files.

Please can someone help?

Regards,

Gerald


Alex Tumwesigye

Technical Advisor - DHIS2 (Consultant),
Ministry of Health/AFENET

Kampala

Uganda

IT Consultant - BarefootPower Uganda Ltd, SmartSolar, Kenya

IT Specialist (Servers, Networks and Security, Health Information Systems - DHIS2 ) & Solar Consultant

+256 774149 775, + 256 759 800161

"I don’t want to be anything other than what I have been - one tree hill "

Dear Alex,

From the link you shared i am only seeing 2.10 to 2.20. I can't find

2.6 to 2.9. Please help me and don't forget i am using dhis2-live for
my test case.

···

On 9/26/15, Alex Tumwesigye <atumwesigye@gmail.com> wrote:

Dear Thomas,

2.5 is a very old version. There has been many changes till 2.20.
I would suggest that you do a systematic upgrade 2.5 to 2.6 to 2.7 to
2.8......2.20.
It is a simple process you need to stop the tomcat server, then dump the
war file and start the server again for each version.for version 2.13 to
2.20.you may need to run upgrade scripts before dumping the war file.

You can get war files from https://apps.dhis2.org/ci

Good luck.

Alex

On Friday, September 25, 2015, gerald thomas <gerald17006@gmail.com> wrote:

Dear All,
I am trying to upgrade one of our local (standalone server) instances
of dhis2 which was running on version 2.5. I exported the database and
import the database into a dhis2-live version 2.20.
The application is running on windows and my database is PostgreSQL
9.3.9. The upgrade was successful but when i ran "Data Set Report" for
a particular Data Set; i am getting a blank report.

I tried to do "Analytic and Data Mart" but i am getting error. Please
find the attached log files.

Please can someone help?

--
Regards,

Gerald

--
Alex Tumwesigye

Technical Advisor - DHIS2 (Consultant),
Ministry of Health/AFENET
Kampala
Uganda

IT Consultant - BarefootPower Uganda Ltd, SmartSolar, Kenya

IT Specialist (Servers, Networks and Security, Health Information Systems -
DHIS2 ) & Solar Consultant

+256 774149 775, + 256 759 800161

"I don't want to be anything other than what I have been - one tree hill "

--
Regards,

Gerald

Dear All,
Where can i download old DHIS 2 live (2.7 or 2.9 or
2.10............2.19). I am trying to see if that will help me analyze
my issues properly.

Please help me.

···

On 9/26/15, gerald thomas <gerald17006@gmail.com> wrote:

Dear Alex,
From the link you shared i am only seeing 2.10 to 2.20. I can't find
2.6 to 2.9. Please help me and don't forget i am using dhis2-live for
my test case.

On 9/26/15, Alex Tumwesigye <atumwesigye@gmail.com> wrote:

Dear Thomas,

2.5 is a very old version. There has been many changes till 2.20.
I would suggest that you do a systematic upgrade 2.5 to 2.6 to 2.7 to
2.8......2.20.
It is a simple process you need to stop the tomcat server, then dump the
war file and start the server again for each version.for version 2.13 to
2.20.you may need to run upgrade scripts before dumping the war file.

You can get war files from https://apps.dhis2.org/ci

Good luck.

Alex

On Friday, September 25, 2015, gerald thomas <gerald17006@gmail.com> >> wrote:

Dear All,
I am trying to upgrade one of our local (standalone server) instances
of dhis2 which was running on version 2.5. I exported the database and
import the database into a dhis2-live version 2.20.
The application is running on windows and my database is PostgreSQL
9.3.9. The upgrade was successful but when i ran "Data Set Report" for
a particular Data Set; i am getting a blank report.

I tried to do "Analytic and Data Mart" but i am getting error. Please
find the attached log files.

Please can someone help?

--
Regards,

Gerald

--
Alex Tumwesigye

Technical Advisor - DHIS2 (Consultant),
Ministry of Health/AFENET
Kampala
Uganda

IT Consultant - BarefootPower Uganda Ltd, SmartSolar, Kenya

IT Specialist (Servers, Networks and Security, Health Information Systems
-
DHIS2 ) & Solar Consultant

+256 774149 775, + 256 759 800161

"I don't want to be anything other than what I have been - one tree hill
"

--
Regards,

Gerald

--
Regards,

Gerald

Dear Gerald,

Please see this link http://dhis2.org/download/releases/2.X/dhis.war where X is the version.

I managed to get from 2.7 onwards.

Alex

···

On Sat, Sep 26, 2015 at 11:29 PM, gerald thomas gerald17006@gmail.com wrote:

Dear All,

Where can i download old DHIS 2 live (2.7 or 2.9 or

2.10…2.19). I am trying to see if that will help me analyze

my issues properly.

Please help me.

On 9/26/15, gerald thomas gerald17006@gmail.com wrote:

Dear Alex,

From the link you shared i am only seeing 2.10 to 2.20. I can’t find

2.6 to 2.9. Please help me and don’t forget i am using dhis2-live for

my test case.

On 9/26/15, Alex Tumwesigye atumwesigye@gmail.com wrote:

Dear Thomas,

2.5 is a very old version. There has been many changes till 2.20.

I would suggest that you do a systematic upgrade 2.5 to 2.6 to 2.7 to

2.8…2.20.

It is a simple process you need to stop the tomcat server, then dump the

war file and start the server again for each version.for version 2.13 to

2.20.you may need to run upgrade scripts before dumping the war file.

You can get war files from https://apps.dhis2.org/ci

Good luck.

Alex

On Friday, September 25, 2015, gerald thomas gerald17006@gmail.com

wrote:

Dear All,

I am trying to upgrade one of our local (standalone server) instances

of dhis2 which was running on version 2.5. I exported the database and

import the database into a dhis2-live version 2.20.

The application is running on windows and my database is PostgreSQL

9.3.9. The upgrade was successful but when i ran “Data Set Report” for

a particular Data Set; i am getting a blank report.

I tried to do “Analytic and Data Mart” but i am getting error. Please

find the attached log files.

Please can someone help?

Regards,

Gerald

Alex Tumwesigye

Technical Advisor - DHIS2 (Consultant),

Ministry of Health/AFENET

Kampala

Uganda

IT Consultant - BarefootPower Uganda Ltd, SmartSolar, Kenya

IT Specialist (Servers, Networks and Security, Health Information Systems

DHIS2 ) & Solar Consultant

+256 774149 775, + 256 759 800161

"I don’t want to be anything other than what I have been - one tree hill

"

Regards,

Gerald

Regards,

Gerald

Alex Tumwesigye

Technical Advisor - DHIS2 (Consultant),
Ministry of Health/AFENET

Kampala

Uganda

IT Consultant - BarefootPower Uganda Ltd, SmartSolar, Kenya

IT Specialist (Servers, Networks and Security, Health Information Systems - DHIS2 ) & Solar Consultant

+256 774149 775, + 256 759 800161

"I don’t want to be anything other than what I have been - one tree hill "