Update Organization Units

Hello everyone.

I’ve tried solutions from various posts but nothing seems to be working. I’m trying to update the code column for my org units using the Import App but I keep getting the following error:

I’ve set the import as follows:


Weirdly, when I select “Import strategy: Merge - Import new values and update existing”, it tries to create a new org unit even though a unit with the uid already exists.

Any guidance on this? Thanks in advance!

Hi @Clara, welcome back to the community! :tada:

Kindly ensure that the name, uid, shortname & description on your instance corresponds with what is on your import file.

Also, is the last picture a screenshot of the file you’re trying to import? If yes, I think the problem might be from there. You are supposed to have each variable in a column (without the comma) - as shown in the image below.

I hope our response is able to solve the issue you were facing.

1 Like

Thanks for your response!

  • I tried separating the fields into columns and it’s giving me the same issues.

  • The naming conventions in the upload match our DHIS2 instance (2.37.4)

  • I also tried using either id or uid as the identifier and getting the same results.

@Clara I recreated the issue on DHIS2 play, and I’d suggest a couple of things:

  1. If the organisation unit you’re trying to update is not the root orgUnit, you will need to include the ‘parent’ variable in your import file and input the uid for the parent orgUnit.
  2. If you’re updating the root orgUnit, leave the “parent” variable empty.
  3. You should still use the “Import strategy - merge” option.

    Below is a sample of the file I used and it worked.

I hope our response is able to solve the issue you were facing.

With :heavy_heart_exclamation: from the Dhistance Team.

DHISTANCE: The Easiest DHIS2 Setup. Up and running in 5 minutes!

No technical knowledge needed! Great Support with Data Security/Confidentiality.


Thanks for the assistance. I created this excel and tried to import to play and I’m getting the same issue where it creates and doesn’t update. Does it update for you?


@Clara what version did you use on DHIS2 play? And yes, it updated when I tried it.

I’ve tried on both 2.37 and 2.39. Both are creating new instead of updating the existing org units. Do you mind sharing screenshots of your import parameters?

Thank you.

Hello, @Clara
Here are the screenshots of my data and import parameters.