Unable to visualize data in Android App


I have configured visualisations for Android App. I have created a visualisation using ‘Data Visualiser’ with indicators as data. This indicator contains data elements. The visualisation is working fine in web. But when I tried to access this visualisation in Android App, I’m getting “you don’t have access to dataelement”. This happened for only few visualisations. May I know what could be the main reasons?
Thank you!


Hi @Katta_Nityapriya

Are you accessing these visualizations on android using the same account that you use on web?

What type of visualizations are you trying to preview? Are these from data sets (aggregate data) or from Tracker?

Additionally, please double check that these visualizations are added to the Android configuration from the Android Settings app - Analytics settings (source):

I hope this helps! (:

Hi @Gassim , Yes I’m using the same user in both android and web.
I’m trying to visualize aggregate data from data sets, using data visualizer app.
Actually I have not added the visualizations in the ‘Data set’, but have added in the ‘Home’ of ‘Analytics’ in the Android Settings app.

When I checked all the data sets associated with the data element for which it is showing issue in the android app, we noticed that the org unit which is selected in that user’s ‘data capture and maintenance org units’ is not selected in any of these data sets. When we added that org unit to one of these data sets, we are not seeing the error anymore. So, we are assuming that Android app is fetching data elements through the data sets. May I know if our assumption is correct?
Looking forward for your reply!

Thank you!

Yes, the data elements need to be in a data set or a program to be able to be used in analytics.

So we can say that the issue above has been resolved?


Yes, the issue has been resolved, thank you so much!
But I just wanted to clarify why this issue is not seen in the web? How does the web work in this case?

1 Like

Okay, I have a general idea about this but maybe you could get a more detailed answer from the documentation or one of the experts. All inquiries requesting data from data elements need to follow the the data model:


We know what data element but we need to know where, when…etc

This is your answer. For the user to access the data in the data element the “where?” question needs to be answered so when you assigned the user these OUs, it worked.

I’m assuming this is because you’ve added the visualization in the ‘Data set’ in Analytics in the Android Settings app… if you remove the visualization from there, sync the app, is the user still going to see it?

I hope this helps… :smiley:


I’m adding the visualization in the ‘Home’ in Analytics in the Android settings app. And I’m able to see the visualization in the Android app. If I remove from there, it is not visible in android app.

1 Like

Okay, good thanks! Good to know it’s working there as well :smiley:

So the solution to the issue was actually assigning the user the OUs. Would you mark that post as a solution?

Also, I hope you got the answer to your question about data element data being requested from the android app. It’s actually because it needed to know “where” but didn’t have access to the OUs for that user. (:

Thanks @Gassim for the support, happy to hear that the issue is solved.

Just to clarify the behavior in the Android app: analytics are evaluated using the local data in the Android app, so the data must be downloaded in the first place. If the dataSet is not assigned to any user’s orgunit, the datavalues for this dataSet won’t be downloaded. The Android app only downloads the dataValues assigned to DataSets that are linked to any user’s orgunit. So @Katta_Nityapriya your assumption is correct and it explains why the data wasn’t displayed in the visualization before.

1 Like

Thanks @vgarciabnz , this clears my doubt.
Thank you for the explanations @Gassim @vgarciabnz !

1 Like