Unable to upload app to app hub

But now stuck with another issue.
I created a simple app using
Creating a DHIS2 Web app | DHIS2 Developer Portal documentation.

But I am unable to upload it to app hub. Please guide me on this issue.
Screenshot of error is attached below.
Thank You!

Hi @sami12111 . If it’s still not working for you to upload the app, you might want to open the network tab and look for the POST to api/apps. There is probably some additional detail in the response there.

1 Like


I am getting this error in the console

Hi @sami12111 ,

It looks like you’re now getting a different error (500) whereas you were previously getting a 409 error. You might now want to check that your localhost is running properly.

If the server is running properly, and you can reproduce the 409 error again, I’d recommend looking in the network tab rather than the console.

For example, in the example below, I can see that my app is missing a required file (and therefore will not upload):

1 Like

Yes the manifest file issue is resolved, now facing that error (500) as you can see the screenshot.

In the network tab I am getting the same error

@tzemp which operating system are you using?

Thanks @sami12111. I’m using a Mac (OS Monterey). I don’t have experience with setup on Windows, but that looks like it could be an issue with your server not having permission to write to that directory (DHIS2/files/apps), so the app cannot be saved.

Thanks @tzemp. do you know from where we can set these permissions?

Hi @sami12111: I’m not familiar with Windows, but this article might be of use: How to change folder permissions on Windows - V2 Cloud

Let us know how it goes, and if that doesn’t help, maybe someone with more set up experience in Windows can weigh in with some advice


I suggest moving the folder DHIS2 somewhere other than the C:\ root. For example, C:\Users\YourUsername\DHIS2\

1 Like

@sami12111, did this suggestion work? If no, have you been able to make it work?


Hope you are doing well.

The solution mentioned above did not resolve my issue. Instead, I moved the application code files directly to the c:\DHIS2\apps\ folder and recompiled the war file, which resolved the problem.



Thank you for sharing the solution @sami12111!

1 Like