Unable to update reports in Data Visualizer App

Hello DHIS2 team,

There is an issue with the analytics of DHIS2, that might be a bug. We have over 100 chart reports spread across 11 dashboards.
When we try to SAVE the period or org units in the data visualizer app, we receive an error (see screenshot, below) Updating happens as it should, but saving is not possible. At this point, we can recreate the reports and place them on the dashboard, but this will be a lot of work. We prefer to open the reports in Data Visualizer -> make changes (e.g. add new periods) and then save, hoping that these changes will appear on the dashboard without the need to recreate reports.

  1. Sharing settings for the reports and dashboards were properly configured and we are using an admin group
  2. We haven’t experienced such an issue with DHIS2 in the past, so it could be the version.
    Any thoughts?
  3. DHIS2 version is 2.34.1

Kind Regards,

1 Like

Hi @Kristiyan_Panayotov,

Have you tried upgrading 2.34.3 to see if the issue still persists there?

Are you receiving any sort of console error when you attempt to save?


Hi @Karoline - Thank you for looking into this!

I haven’t tried upgrading, yet - version 2.34.3 just came out (yesterday). We can try that, soon.

I get a console error saying:

“VM1111:1 PUT https://data.nascents.org/api/32/visualizations/eR5QJ0pdnBM?skipTranslations=true&skipSharing=true 409 (409)”