Unable to load dataelements to create indicators


Am trying to create indicators for my dhis2 instance but the problem is that my dataelements cannot load under edit numerator/denominator section in the Indicator feature.

I am using dhis2 live 2.29 with PostgreSQL in the windows environment. Is there any thing i can do to get over this. I have alread posted this question on the mailing list and awaiting for response.




I am having same problem, please has anyone got a solution to this? Data element does not appear on the calculation window when double clicked, using DHIS2 2.29 also…

1 Like

Noticed its a browser issue, tried this action on another browser other than explorer and it worked.

1 Like

Hi Allan and Thankgod,

You can try clearing the cache for the web browser and for the DHIS2 cache app, then retry loading the DE. Also try using a private window (incognito) and see if the DE loads because they are supposed to load by default*


1 Like

We are having the same issue i.e. data elements do not load on indicator numerator/denominator. We have tried everything including what is said above and more but did resolve issue.

  • Different browsers (Chrome, Edge), cleared browser cache, tried incognito mode
  • Cleared applicable cache from DHIS2 “Data Administration”
  • Upgraded DHIS2 from 2.33.6 (what we had before) to 2.34.6
  • Upgraded Tomcat server from 8.5 to 9
  • Upgraded Postgres database from 12 to 13

Each step was done one by one and checked the indicator UI but didn’t fix the issue. Also tried setting up a new DHIS2 environment with the same software and it didn’t have issue. So there is obviously something in the data elements list that is causing issue. But the data element UI and API both work fine and get the results. We have about 450 data elements total.

We also tried to check the logs to figure out what request is being made at that time and hanging. But there are no errors in the log.

Any tips or guidance is appreciated.

@cbhatt would you please create a video, GIF, or a number of screenshots to aid the post? I have asked for support, but usually it’s also important for the experts to have a look at logs to understand if there’s an issue.

Hope it’ll be resolved for you! What I’d do if I’m sure that this is caused by the data elements is try to figure out which data elements. I mean if you export all the 450 data elements into the new instance do you start getting the same issue? If yes, I’d delete them from the new instance and start by dividing the 450 into smaller groups to see if this is happening only to a certain number of data elements. However, I hope you’ll find a better solution @dhis2-analytics.

@cbhatt like I said, it’s important to see the logs for the experts to answer. Would you please share the tomcat log and potential errors from the browser console (and the Network tab to see the requests) . Thank you!