Unable to create event layer in maps app in 2.30

Hi all

I am trying to create an event layer map in 2.30. I know there is data as this was working previously in 2.29. I notice in the log when I try to add the event layer I receive the following error message:

ERROR: column ax.geom does not exist

I have installed postgis and ran the upgrade script, but perhaps I am missing something else here? Has anyone encountered this before?




Shurajit Dutta (MPH, MHI)
Health Information Systems Adviser

Hi Nick

We have also just upgraded to 2.30 and are experiencing similar issues. We had various maps using event data that was working in 2.28, but now when I look into the event data itself, it seems that the coordinates have all been lost. The name of the field has changed from “Coordinates” to “Geometry”. I am not sure if this may be part of the issue?

When I tried to update the event data with some coordinates, I select coordinates, update the event entry and then ran analytics to see if this would rectify the problem. This did not seem to work. I then entered a new event entry and subsequently ran analytics again and it seems that it is still not depicting on the map. When going back to that same event entry, I see that the coordinates once again are not available and the field is blanked. Interestingly, all of the graphs attributed to the event data (e.g. sex distribution etc.) are still working - therefore I suspect that this has to do with the event coordinates only and not the actual event data entry.

I have cleared cache and tried to create an entirely new map (using both GIS and the new Maps app) and none of this has helped either.

Any help would be appreciated, as we have lost all of our maps.

Kind regards,



Terence Scott

Global Alliance for Rabies Control (GARC)

Pan-African Rabies Control Network (PARACON) Steering Committee



Skype: tpscott1987