Troubleshoot issue with data entry APP

Following the system updagrade to version 3.9, the “data entry app” does not run the dataset selection after selecting the organization unit on the right side (please see the attached photo).
What could the issue be? How can it be solved?



Hello @p.belardi
There are two options that you should check:
1- Ensure that the health facility OU is activated within the dataset.
2- Ensure that user role is activated data value within Metadata Authorities.

Best regard

Thank you @jamal_aljadan . I checked both the options and everything is ok.
Do you have other suggestions?


Could you please check on sharing settings for the dataset as below picture :

Good morning,
yes, they are all set llike in your picture. The problem persists .
Before the upgrade to the new version of the system, data entry app worked very well without this bug for more than 2 years.
Could it be possible that is a technical problem?

Which DHIS2 version are you using? Can you reproduce this situation on the demo on the same version just to be sure.

I checked in the demo version and everything is ok

Any other suggestions on how to solve it?

Hi @p.belardi. Sorry that you’re having problems with the data entry app.

Could you open the developer console* and share the information that is shown there (if any)? That might help us better understand the issue and see if it’s a configuration issue or an issue that needs to be fixed in our codebase.

  • Shift + CTRL + J (on Windows/Linux), or Option + ⌘ + J (on macOS)

Thanks @tzemp .
Here are the screen shots:


Thanks, @p.belardi

I believe your problem is due to an issue which has been reported (DHIS2-15011) and fixed. The 2.39.2 release will hence include the fix and should be released within the next couple of weeks.

If you need to address the issue more urgently, there is a work around that involves adding some additional metadata into your system. See this post for example: Data entry app not loading - #21 by jaime.bosque

1 Like