Tracker Program Stage Loads Forever

Hello,

I am currently running dhis-2.28 and am facing some issues with the Tracker Program stage.
Some of my Program stages are unable to load and show the data entry form input fields. It loads forever as indicated in the Image attached.

2 Likes

Greetings community,

Could anyone have faced this challenge before where program Stages are not loading? @jomutsani

.

2 Likes

Hi @mauriceelagu,

We will need a bit more information in order to identify the problem. For starters:

  1. Are there any console errors in the browser?
  2. Are there any failed API calls?

You can find out by opening “developer tools” in your browser and looking at the console and network tabs.

3 Likes

Hi @Gintare,

Yes, I have 2 console errors, "TypeError: Cannot read property ‘timelineDataEntryMode’ of undefined
"

4 Likes

@Markus, @Joakim, any ideas on what could be wrong?

3 Likes

In most recent I have been facing the similar challenge with the same Error. I am managing several tracker instances, and most of them are running at 2.30 (Everything is okay). 4 out of 6 tracker instances show the same error, only 2 was success. The challenge raises when I upgrade to 2.31 or 2.32 and even 2.33. All acts on the same way. Unfortunately, tomcat logs doesn’t capture any error and the Data Integrity seems to be okay. We have to depend on Console alone.

I am using PostgreSQL 10, and tomcat 8.5 . I added lines on server.xml
relaxedPathChars="[]|"
relaxedQueryChars="[]|{}^\`"<>"

It is still the same story. I will appreciate for you help. Should anyone be interested to access one of my dev system to examine the problem is welcome.

2 Likes

It is strange though. I was going through different threads in here. I come across with a thread Failed to save the enrollment to the server , there is a clue from @chase.freeman about the bugs reported on Jira https://jira.dhis2.org/browse/DHIS2-7865.

I changed the Tracked Dashboard from ‘Unlock layout for all users’ to ‘Lock layout for all users’ . It solved a problem at my side. It worth a try.
image

5 Likes

Thanks a bunch @sele,

Changing the Tracked Dashboard from ‘Unlock layout for all users’ to ‘Lock layout for all users’ solved the problem for me aswell.

regards

3 Likes

I also found the same issue on 2.32.2 after we recently upgraded. We experienced the same issue, but had our tracked dashboards already locked for all users. We therefore unlocked them and this worked (as suggested).

This must be done for every tracker program that you have individually though, so be sure to go through each program to ensure that the issue is resolved.

2 Likes

@Karoline Can we get someone to look into this–it got skipped in the last patch updates: https://jira.dhis2.org/browse/DHIS2-7865?filter=-2

Lots of people seeming to have issues

2 Likes

Hi @chase.freeman, thanks for tagging me and highlighting the issue. I’ll follow up with the Tracker team here!

1 Like

Thank you! :pray: :blush:

2 Likes

Hi everyone!

Happy to inform you that we fixed an issue where layout locking feature was causing failure. The fix will be available in 2.34 and all upcoming patches (2.31 to 2.33).

/ Gintare

1 Like