Tracker failing to load meta data

Hello friends,

I have this issue, i am failing to register a tracked entity, what should i do? I hget this error

Hi @mkatusiime,

So glad to have you as part of the community.

A quick one - Have you checked on the Sharing settings for metadata objects for your program? also kindly check if the Org Units assigned to the program, then the user roles and user groups assigned - if they have the right authority.

Let us know if this helps.

Best,
James.

Hello @jomutsani thanks for the feedback but i have tried to created a new user and assigned roles and org units but, it still fails to load the metadata

1 Like

Hey @mkatusiime,
I would check specifically https://docs.dhis2.org/2.30/en/user/html/dhis2_user_manual_en_full.html#data-sharing-and-access-control
This part covers the “data” sharing that you need to set up from version 2.29 and up.

The error message you get in the tracker seems to indicate that you do not have “Data write” or “Data read” access to the tracked entity type(s) that your program(s) are connected to. Please have a look, and make sure you have shared the tracked entity types, programs and program stages with the user or group that will access them.

Markus

1 Like

Hello @Markus, Check everything is set but still, i get the same error

1 Like

@mkatusiime

That “Failed to load meta-data” error is often caused by the new restriction for tomcat 8.0.35 or later (it blocks by default the use of square brackets in queries).

If you are using 8.0.35 or later, make sure you have relaxed this constraint in your tomcat’s “server.xml” configuration file.

Otherwise, make sure that the trackedentitytype table has publicaccess set correctly:
UPDATE trackedentitytype SET publicaccess = ‘rwrw----’;

Best regards
Calle

1 Like

@mkatusiime,
It seems the TEType setup is correct, and therefore the user message above is just part of the symptoms, not the problem.
Unless you already solved it by trying some of the things Calle suggested, we might benefit from gathering some more information from you in order to find the cause of the problem.

What is the operating system and tomcat version of the machine running DHIS2?

Can you also clear your browser cache, open your browsers developer console, and then open the tracker? This will give us more information of what is failing when the metadata is downloaded.

Best,
Markus

1 Like

Hi All

We actually experienced this issue on one of our user’s computers. We eventually found out that it was a setting in Google Chrome that was blocking content (popups and Java). Once we allowed content for the site, it loaded the metadata.

Try testing this on another browser or computer to see if it resolves the issue.

2 Likes