Tracker data dose not show in event report

Dear valuable community greetings.

I have three tracker programs A, B and C in my DHIS2 instance i have created tracked entity attributes, data elements and option sets for program A.

When i have assigned some of attributes and data elements with option sets of program A to program B as well as program C. The problem is, program A shows data in event report but program B and C does not show data in event report. What is the problem with these two (B, C) programs while all the configuration is the same, please help me to solve?

Note: The organization unit is the same

Jan Agha Stanikzai

Hi Jan,
Have you captured data in tracker capture for programs B and C, and you can see the data for the TEAs and DEs in tracker capture (like you can see TEIs enrolled in tracker capture), but you are not seeing anything in event reports?

Have you run analytics tables in the data administration app and cleared your cache?


Thank you very much @Natalie_Tibbels for your suggestion.

Clearing cache does not work, while running analytic tables do work but it shows data from the org unit’s children not org unit itself, it makes me worry because I do not have such enrollments in tracker capture or may be deleted from the lists in the past (Org unit children’s data).

Thanks and Regards
Jan Agha Stanikzai

Thanks @Natalie_Tibbels! (:

Did you try Data Administration app → Maintenance? Please see the selected options in the image!

Dear @Gassim and @Natalie_Tibbels thank you very much for your assistance and directions, the problem have been solved and now working find, great guys

Thank you
Jan Agha Stanikzai

1 Like

How did you resolve the issue? I have the same problem in version 2.38.1 and tried all the suggestions above but nothing is working.

1 Like

Dear @WaluQ
In Data Adminstration module first select maintenance, select the options shows in first picture and run the performence maintenance.
Second: Select Analytics Table and click on start export it will update analytics tables (as shows in second picture) then enter data and look the results.

I hope this will help you

Jan Agha Stanikzai

1 Like

6 posts were merged into an existing topic: Possible Memory Leak with Version 2.37.3