Tracker Capture App not working in DHIS 2.29

Hi All,

I did a migration of DHIS2 from version 2.27 -> 2.28 -> 2.29.

The tracker capture app is not loading properly and is throwing console error

"TypeError: Cannot read property ‘id’ of undefined

at n.$scope.hasProgramTetAccess (home-controller.js:264)"

I find that the object store ‘trackedEntityTypes’ has no data in indexed DB.

I have cleared all the browser cache and have tried opening DHIS in multiple browsers. I am getting same error every time.

It was an incremental upgrade and I have not used the upgrade script provided by DHIS.

What can be the possible reason behind this?

Do I need to use upgrade script even if I do an incremental upgrade?

···

Kumar Gaurav Nath Shahdeo
Developer
Email
gauravns@thoughtworks.com
Telephone
+91 9160688935
ThoughtWorks

1 Like

Hi,

It is necessary to use the upgrade script BEFORE running 2.29.

···

Abyot A. Gizaw.

Senior Engineer, DHIS2

University of Oslo

http://www.dhis2.org

1 Like

I also would want to learn the way round.

···

On Thu, Jun 14, 2018, 14:46 Kumar Shahdeo gauravns@thoughtworks.com wrote:

Hi All,

I did a migration of DHIS2 from version 2.27 -> 2.28 -> 2.29.

The tracker capture app is not loading properly and is throwing console error

"TypeError: Cannot read property ‘id’ of undefined

at n.$scope.hasProgramTetAccess (home-controller.js:264)"

I find that the object store ‘trackedEntityTypes’ has no data in indexed DB.

I have cleared all the browser cache and have tried opening DHIS in multiple browsers. I am getting same error every time.

It was an incremental upgrade and I have not used the upgrade script provided by DHIS.

What can be the possible reason behind this?

Do I need to use upgrade script even if I do an incremental upgrade?


Kumar Gaurav Nath Shahdeo
Developer
Email
gauravns@thoughtworks.com
Telephone
+91 9160688935
ThoughtWorks


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

1 Like

The answer is yes.

···

On Thu, Jun 14, 2018, 2:45 PM Kumar Shahdeo gauravns@thoughtworks.com wrote:

Hi All,

I did a migration of DHIS2 from version 2.27 -> 2.28 -> 2.29.

The tracker capture app is not loading properly and is throwing console error

"TypeError: Cannot read property ‘id’ of undefined

at n.$scope.hasProgramTetAccess (home-controller.js:264)"

I find that the object store ‘trackedEntityTypes’ has no data in indexed DB.

I have cleared all the browser cache and have tried opening DHIS in multiple browsers. I am getting same error every time.

It was an incremental upgrade and I have not used the upgrade script provided by DHIS.

What can be the possible reason behind this?

Do I need to use upgrade script even if I do an incremental upgrade?


Kumar Gaurav Nath Shahdeo
Developer
Email
gauravns@thoughtworks.com
Telephone
+91 9160688935
ThoughtWorks


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

1 Like

Hi Stanley,

There is no way around. To use 2.29, one needs to run the upgrade script first.

···

Abyot A. Gizaw.

Senior Engineer, DHIS2

University of Oslo

http://www.dhis2.org

1 Like

Ok, thanks for the clarification.

···

Kumar Gaurav Nath Shahdeo
Developer
Email
gauravns@thoughtworks.com
Telephone
+91 9160688935
ThoughtWorks

1 Like

A post was split to a new topic: Tracker Capture in 2.29 - “failed to load metadata”