Tomcat8_DHIS2 not starting

I installed and ran DHIS2 on tomcat 8 a week ago and everything was going fine. To start the tomcat server, I had to click on Tomcat8_DHIS2, wait for the cmd to stop running, then start the Tomcat8_DHIS2w. Everything was going fine until the Java version on my PC got updated. I changed the PATH environment variable, but still, it did not work. What happens is that the Tomcat_DHIS2.exe simply does nothing. It blinks for a fraction of a second then nothing happens. Naturally, localhost:8080 does not work either.

Can anyone help me pinpoint the source of the problem, please? I can’t seem to find anything on google or stackoverflow.

Hi @Christian_Rechdan.
which version is your JAVA now? And are you able to share the logs?
Secondly, let’s compare your java version with what you have added in the config file.
Are you able to provide this information?



I solved it! The problem was that another application (Oracle database) was using the same port as Apache Tomcat (port 8080). When I stopped the Oracle database service, Apache Tomcat worked with no problem, and I was able to access DHIS2.
For anyone facing the same problem, you could have also solved it by changing the port number of either Oracle or Apache Tomcat.