systemSettings API not working according to documentation

Can someone explain to me why the systemSettings API examples don’t work for at least these four key/value pairs? I cannot POST or PUT to change the values. I’ve tried passing them as plain/text, JSON, and as parameters, all which should be valid according to the docs:

  1. credentialsExpires
  2. credentialsExpiryAlert
  3. accountExpiryAlert
  4. accountExpiresInDays

How else are we supposed to fine-tune our account management policies? The preset expiries are insufficient for our needs.

Any insights would be appreciated. Note - I am not trying to add or customize the settings but to set the values within their reasonable scope.

Hi @chase.freeman,

I tried this POST request and it worked – accountExpiresInDays is not supported in versions older than 2.37 but the POST request, worked in 2.36.10…

However, the same requests in 2.38.0 give me a result “Access Denied” and this is probably because the new personal access tokens settings. I think to perform that request in 2.38.0, we’d need to create a token for that first. DHIS v2.37 Platform - Personal Access Tokens - YouTube

1 Like

Thanks for your help @Gassim - Either way it is mess to manage and should be prioritized as it is closely related to managing the security of one’s DHIS2 instance.