SEVERE: Failed to start connector [Connector[HTTP/1.1-auto-1]]

blank page i see this error in catalina.log

SEVERE: Failed to start connector [Connector[HTTP/1.1-auto-1]]

org.apache.catalina.LifecycleException: Failed to start component [Connector[HTTP/1.1-auto-1]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:153)
at org.apache.catalina.core.StandardService.startInternal(StandardService.java:460)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:147)
at org.apache.catalina.core.StandardServer.startInternal(StandardServer.java:738)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:147)
at org.apache.catalina.startup.Catalina.start(Catalina.java:693)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:294)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:428)
Caused by: org.apache.catalina.LifecycleException: The connector cannot start since the specified port value of [-1] is invalid
at org.apache.catalina.connector.Connector.startInternal(Connector.java:1000)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:147)
… 11 more

May 24, 2018 7:55:05 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 37521 ms

whats the solution

···

developer_lusaka_systems

2 Likes

Moses,
On the server.xml file change
Connector port=“HTTPPORT” address=“127.0.0.1” protocol=“HTTP/1.1” proxyPort=“443” scheme=“https”
URIEncoding=“UTF-8”
executor=“tomcatThreadPool” connectionTimeout=“20000” relaxedQueryChars="[]" />

Connector port=“8080” address=“127.0.0.1” protocol=“HTTP/1.1” proxyPort=“443” scheme=“https”
URIEncoding=“UTF-8”
executor=“tomcatThreadPool” connectionTimeout=“20000” relaxedQueryChars="[]" />

2 Likes