Setting up DHIS2 environment


I am trying to set up the environment for DHIS2. I have followed this guide for the set up: Getting started with DHIS2 : Development in platform ecosystems

Everything works as it should until I reach the step " Logging in from your application". When i try to log in from localhost:3000 i get this error-message:

I appreciate all the help!

Hi @zhara

Did you try this step successfully npx dhis-portal --target= If it’s still not working, could you try again without using “dhis2-portal”, and you can follow these specific steps here: Environment Setup | DHIS2 Developer Portal

If it still doesn’t work, please share more logs:

  1. Right before the error appears, open the DevTools (F12) and make sure the Network tab is open. After the error appears, search for the error in the Network tab and get the response/resquest
  2. Check the console for the error (F12)
  3. If this is actually a server error, then we need the Catalina.out log to see what’s going on. BTW, what DHIS2 version did you install?


Hi @Gassim! Thank you for your response😊

I assume i run the step you mentioned successfully. This is the response i get in my terminal:

When i run the command without “dhis2-portal” i get this in my terminal:

I dont really know what to do from here.

How do i find the Catalina.log?

I installed DHIS2 by following this guide: Getting started with DHIS2 : Development in platform ecosystems
I installed DHIS2 by running this command: yarn global add @dhis2/cli

It seems like i have this version installed on my computer: @dhis2/cli@4.2.3

These are the versions they use in the dependencies in package.json:

Hi @zhara

I noticed from the terminal that your system is MacBook Air, maybe this is why the installation isn’t working? Did you try to use Docker as explained here: (DHIS2 in Docker | DHIS2 Developer Portal)

The log can be viewed with the following command:

tail -f tomcat-dhis/logs/catalina.out

Please don’t copy/paste the log without removing sensitive/authentication info.

Regarding connecting to the course online instance, I have not tried it but I suspect that if could be the reason why it’s not working so you might try to use the other guide I shared and neglect the “dhis2-portal” step?


I get the same error message when i follow the guide you shared.

I cant seem to find the log from catalina.out

Again, thank you. I appreciate the help!

The problem was that i was using an outdated version of chrome! Fixed it by updating chrome. Everything works as it should now😊


Thank you for sharing the solution and I’m glad you figured it out. :pray:Good luck with the course :slight_smile: