Server error when adding relationship

Trying to create a relationship between TEIs of the same type in two different programs through the GUI in 2.33.3 Seemingly the database query is missing references to the actual TEIs (last two columns get set to null). Is there some obvious configuration that I am missing?

Here is the server error:

Caused by: org.postgresql.util.PSQLException: ERROR: null value in column “trackedentityinstanceaid” violates not-null constraint
Detail: Failing row contains (193996, T9zrLymUahP, null, 2020-03-04 13:39:55.047, 2020-03-04 13:39:55.047, 52552, null, null, null, 42988, 193997, 193998, null, null).

1 Like

Hi @Knut_Staring,

When you say 2.33.3, you mean 2.33dev, right?Just tried this in the 2.33 dev play server (with bidirectional relationship of TET “Person” between the Child Program and the MNCH / PNC (Adult Woman) Program), I didn’t have any issue? Can you try to reproduce on play?

Thanks,
Karoline

I should have said that I had already tried that and it did work, so has to be something with my local, almost blank setup. Was hoping someone could think of an obvious error I must have made (of course also keen to have more useful feedback in the application rather than whatever I did in the user interface cause a server error).

1 Like

@Stian can you have a look at this one?

1 Like