Server connection failed for API request - Users app not loading in Windows installation

Dear all,

We have a Windows installation with apache as webserver. We have configured wildcard DigiCert as well. Everything seems working fine except few apps like Users. When we try to access Users - we get the following error.

Have anyone faced this issue before?

Hi @jthomas

The error is generic and doesn’t help indicate why this is happening. Is it possible we get more info from the console and the network requests for more information about the error?

Thanks!

1 Like

Hi @Gassim (thanks for reminding you to troubleshoot further) and I would like to update this thread since i could find the reason and solution. In the developer tools-> console it was showing “Mixed Content” error and following configuration in the tomcat server.xml fixed the issue. I think it’s more a windows specific issue

we had to explicitly give scheme="https" and proxyPort ="443"

2 Likes

Thanks for sharing the solution @jthomas! :slight_smile:

1 Like

Hi @jthomas, I have a similar issue with my DHIS2 setup and tried what you mentioned. But it is still not working. Please can you or @Gassim support me here?

Thanks

Hello @Bidemi_John May be you post your exact error and also catalina log file and community can comment perhaps?

1 Like

Thanks, @jthomas, I found the error and fixed it. The issue is with the nginx.conf file.

1 Like