Selecting multiple answers on options sets

Is there a way of selecting multiple answers on options sets (question with answers under options sets)

Regards

Hi
If you are using a version 40 or later, this is a new feature that was introduced last year: YouTube: DHIS2 V40 - Multi Select Option Sets

I hope this helps! :slight_smile:

Hi @Gassim

Thank you very much. I was aware of this, but I was referring to multiple selection on a tracker or event program. Yes, I know the multiple selection was introduced in version 2.40, but specifically for aggregate data.

So, can we select multiple option sets in a tracker program?

Regards

1 Like

Oh, I thought it worked in both the aggregate as well as tracker since option sets are used by both models… I’m not sure, if you say it’s not then I will try it myself as well.

If it’s not then maybe this could be raised as a feature request? (See ideas) :smiley:

1 Like

@Gassim I assumed the same; tried to set it up on play and received:
image

Hi Matt! It should work for Tracker from v41. :slight_smile:

1 Like

@Karoline @Gassim Does it really work on that version 41? I have tried but not working .

Regards

Hi,

It should, yes. You need to create a data element of type Text with multiple values that also has an option set of value type Text with multiple values, and make sure your Capture app is version 100.34.0 or above.

If this still doesn’t work, it would be great if you provide some more information of what exactly does not work (Is it the configuration in Maintenance? Is it the form in Capture?) and some screenshots/screen recording.

Thank you so much!
Karoline

@Karoline I see the functionality now. Let me try to develop the tracker program and see if it works the way I want. I will send feedback. Thank you

@Karoline i request one more help , How do I import metadata for an option set with multiple values? Attached is the CSV file that works well when I import an option set with a single selection option. Now, I want to import an option set with many values and set the value type to “Text with multiple values.” I have tried, but by default, the value type is set to TEXT, while I need it to be "Text with multiple values.
Comprehensive_Option_Set_Text_with_Multiple_Values.csv (412 Bytes)