Section form (data disappeared) V.2.33.3

Hi Experts,

We’re using a version 2.33.3, I created a section form and whenever the user enters data to the dataset (using data entry app) it disappear if he clicked refresh and it doesn’t show anywhere.


Guys, I tried to the default form and it works fine, so I deleted the section form but then the data entry app keeps loading and not showing the org units :frowning:

It’s a production server, appreciate your prompt support

Have you tried clearing your cache and reloading?

For the organisation units, try searching for any unit using the search icon.

Thank you Banga, I cleared the cache but it didn’t work. Then I deleted the dataset and created it again and it works now. the dataset is assigned to province level and I noticed that the end user use the country in the DataEntry screen rather than provinces in order to get the list of the provinces under the country for sake of faster navigation. when he refresh, he can’t see the values entered as it shows it blank but I checked in the database and I found the data there. so does anyone has idea about this?