'Search' is not working in the org. unit app (2.25)

Hi devs,

It seems that we can not search for the org. unit name in 2.25 in the org. unit app (it is working nice when assigning datasets/programs to org. units) This screenshoot has been taken from the Sierra Leone dev server. It would be nice if you can have a look as soon as you can :), I’m conducting a training this week, and it will be great if I can have this functionality…

Many thanks!

Jose

Hi devs,

any comments about this? It seems that the API calls are working properly:

…/api/25/organisationUnits?fields=id,displayName,path,children%5Bid,displayName,path%5D&query=Asia&withinUserHierarchy=true&pageSize=5

and, despite the API results, the org. tree is not updated

{“pager”:{“page”:1,“pageCount”:1,“total”:1,“pageSize”:5},“organisationUnits”:[{“id”:“aChOCLW4x6p”,“path”:"/FvUGp8I75zV/aChOCLW4x6p",“displayName”:“Asia and Eastern Europe”,“children”:[{“id”:“NC3WdxGafv5”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/NC3WdxGafv5",“displayName”:“Cambodia”},{“id”:“Wdwya6vwsuA”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/Wdwya6vwsuA",“displayName”:“Tajikistan”},{“id”:“G4bzdahEfGk”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/G4bzdahEfGk",“displayName”:“Nepal”},{“id”:“wP7GKqtrpqv”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/wP7GKqtrpqv",“displayName”:“Pakistan”},{“id”:“SucvlskwmEc”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/SucvlskwmEc",“displayName”:“Uzbekistan”},{“id”:“JhZadeGW1b1”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/JhZadeGW1b1",“displayName”:“Viet Nam”},{“id”:“FNd0IL8umaY”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/FNd0IL8umaY",“displayName”:“Kazakhstan”},{“id”:“BHnldctZRU2”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/BHnldctZRU2",“displayName”:“India”},{“id”:“n0WRqDDI9hS”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/n0WRqDDI9hS",“displayName”:“Kyrgyzstan”},{“id”:“lokyW4HIFoB”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/lokyW4HIFoB",“displayName”:“Myanmar”},{“id”:“BPl0166e9lN”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/BPl0166e9lN",“displayName”:“Thailand”},{“id”:“KYmcGPoZWa1”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/KYmcGPoZWa1",“displayName”:“Pakistan (PSI)”},{“id”:“iOEMphjTqsq”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/iOEMphjTqsq",“displayName”:“Pakistan (GreenStar)”},{“id”:“YMF3rvk9tx6”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/YMF3rvk9tx6",“displayName”:“Romania”},{“id”:“PlNMxx2IgQe”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/PlNMxx2IgQe",“displayName”:“Russia”},{“id”:“cLFnzda5eDL”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/cLFnzda5eDL",“displayName”:“China”},{“id”:“ahlcUyvOgQT”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/ahlcUyvOgQT",“displayName”:“Laos”},{“id”:“CWvEma9lkm9”,“path”:"/FvUGp8I75zV/aChOCLW4x6p/CWvEma9lkm9",“displayName”:“Papua New Guinea”}]}]}

···

On Sun, Oct 30, 2016 at 3:06 PM, Jose Garcia Muñoz josemp10@gmail.com wrote:

Hi devs,

It seems that we can not search for the org. unit name in 2.25 in the org. unit app (it is working nice when assigning datasets/programs to org. units) This screenshoot has been taken from the Sierra Leone dev server. It would be nice if you can have a look as soon as you can :), I’m conducting a training this week, and it will be great if I can have this functionality…

Many thanks!

Jose