“Requested dashboard not found issue version 2.33.8

When a user tries to modify a dashboard created by another user, even after having all rights and access sharing setting etc., the user is unable to modify it, the system shows a message saying "“Requested dashboard not found”

The Dhis2 version is 2.33.8

@Consultant could you please take a screenshot of the Network tab after opening it from the console and performing the action again?

I would recommend that you try it again using a clean browser, either clearing the cache or creating a new profile in your browser.

Let me know if you need any assistance in any of these steps. Thanks!

I tried using it but its not helping me

Yes, please while the Network tab is open, perform the same actions, and then please take a screenshot so I can request from the experts to support you.

Thank you!

Please find the image for your reference

Hi, @Consultant!

When it comes to dashboards, it is important to be aware of the following points:

  • make sure that the sharing for the dashboard and the included dashboardItems (charts, eventReports, reportTables, maps) is set up properly. Share the dashboard and its content with a designated User Group.
  • make sure that the user is assigned to the designated user group.
  • make sure that the user has the right user role and that the user role is set up correctly to allow the user access to the analytics tools.
  • Make sure that the cache is cleaned before the user accesses the dashboard.
    (1. Data Administration - Maintenance - reload apps, clear application cache, 2. Cache cleaner, 3. Clear Browser Data).

Hope this. works.

If not, we will need further details in order to investigate the issue.

Good luck.

Thanks Yury,

But when we try to do any changes in the sharing setting the above error comes and then suddenly the dashboard is not visible.

Can you run this api call and send me the json file?

..api/dashboards/{dashboard_uid}.json

1 Like

{“lastUpdated”:“2018-10-04T11:49:56.763”,“id”:“WtJ6zv91VBj”,“href”:“Information management system - KSC 3539”,“displayName”:“YE - KSC 3539”,“publicAccess”:"--------",“externalAccess”:false,“displayFormName”:“YE - KSC 3539”,“itemCount”:13,“favorite”:false,“access”:{“read”:true,“update”:true,“externalize”:true,“delete”:true,“write”:true,“manage”:true},“lastUpdatedBy”:{“displayName”:“Deepali Sahu”,“id”:“ijX29jM1Frv”,“username”:“dsahu”},“user”:{“displayName”:“Deepali Sahu”,“id”:“ijX29jM1Frv”,“username”:“dsahu”},“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“dashboardItems”:[{“lastUpdated”:“2019-08-06T11:05:43.734”,“id”:“dr4V3aSyGER”,“href”:“Information management system Gilmore”,“id”:“fLJzIRxX3BN”,“username”:“cgilmore”},“chart”:{“id”:“bSoIRJMpARp”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]},{“lastUpdated”:“2019-08-06T11:06:14.732”,“id”:“WlwdzeqAvuR”,“href”:“Information management system Gilmore”,“id”:“fLJzIRxX3BN”,“username”:“cgilmore”},“eventReport”:{“id”:“mW6nILDwGAx”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]},{“lastUpdated”:“2018-10-04T11:54:06.827”,“id”:“RfdEqUdn65Y”,“href”:“Information management system Sahu”,“id”:“ijX29jM1Frv”,“username”:“dsahu”},“eventChart”:{“id”:“R4XqvzvIUgr”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]},{“lastUpdated”:“2018-10-04T11:44:28.949”,“id”:“NGYcHImr70G”,“href”:“https://dhis.medmis.org/api/dashboardItems/NGYcHImr70G",“created”:“2018-10-04T11:44:28.949”,“type”:“CHART”,“externalAccess”:false,“contentCount”:2,“shape”:“NORMAL”,“interpretationCount”:0,“interpretationLikeCount”:0,“favorite”:false,“visualization”:{“id”:“hxdSaldyP7n”},“access”:{“read”:true,“update”:true,“externalize”:true,“delete”:true,“write”:true,“manage”:true},“chart”:{“id”:“hxdSaldyP7n”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]},{“lastUpdated”:“2018-10-04T11:54:01.725”,“id”:“CbpjejB1yhV”,“href”:“https://dhis.medmis.org/api/dashboardItems/CbpjejB1yhV”,“created”:“2018-10-04T11:44:03.501”,“type”:“CHART”,“externalAccess”:false,“contentCount”:2,“shape”:“DOUBLE_WIDTH”,“interpretationCount”:0,“interpretationLikeCount”:0,“favorite”:false,“visualization”:{“id”:“vKFlDgNbHM0”},“access”:{“read”:true,“update”:true,“externalize”:true,“delete”:true,“write”:true,“manage”:true},“lastUpdatedBy”:{“displayName”:"Deepali Sahu”,“id”:“ijX29jM1Frv”,“username”:“dsahu”},“chart”:{“id”:“vKFlDgNbHM0”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]},{“lastUpdated”:“2018-10-04T11:44:38.685”,“id”:“xOxGHs90xp3”,“href”:“https://dhis.medmis.org/api/dashboardItems/xOxGHs90xp3",“created”:“2018-10-04T11:44:38.685”,“type”:“EVENT_CHART”,“externalAccess”:false,“contentCount”:1,“shape”:“NORMAL”,“interpretationCount”:0,“interpretationLikeCount”:0,“favorite”:false,“access”:{“read”:true,“update”:true,“externalize”:true,“delete”:true,“write”:true,“manage”:true},“eventChart”:{“id”:“ip8U643g7RY”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]},{“lastUpdated”:“2018-10-04T11:44:37.373”,“id”:“Q3TWV4EarAd”,“href”:“https://dhis.medmis.org/api/dashboardItems/Q3TWV4EarAd”,“created”:“2018-10-04T11:44:37.373”,“type”:“EVENT_CHART”,“externalAccess”:false,“contentCount”:1,“shape”:“NORMAL”,“interpretationCount”:0,“interpretationLikeCount”:0,“favorite”:false,“access”:{“read”:true,“update”:true,“externalize”:true,“delete”:true,“write”:true,“manage”:true},“eventChart”:{“id”:“TJDztIJEANk”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]},{“lastUpdated”:“2018-10-04T11:44:35.657”,“id”:“b7PIunrt1xU”,“href”:“https://dhis.medmis.org/api/dashboardItems/b7PIunrt1xU”,“created”:“2018-10-04T11:44:35.657”,“type”:“EVENT_CHART”,“externalAccess”:false,“contentCount”:1,“shape”:“NORMAL”,“interpretationCount”:0,“interpretationLikeCount”:0,“favorite”:false,“access”:{“read”:true,“update”:true,“externalize”:true,“delete”:true,“write”:true,“manage”:true},“eventChart”:{“id”:“Y3PfFJTOFti”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]},{“lastUpdated”:“2018-10-04T11:44:34.982”,“id”:“gbmNn8ns0n0”,“href”:“https://dhis.medmis.org/api/dashboardItems/gbmNn8ns0n0”,“created”:“2018-10-04T11:44:34.982”,“type”:“EVENT_CHART”,“externalAccess”:false,“contentCount”:1,“shape”:“NORMAL”,“interpretationCount”:0,“interpretationLikeCount”:0,“favorite”:false,“access”:{“read”:true,“update”:true,“externalize”:true,“delete”:true,“write”:true,“manage”:true},“eventChart”:{“id”:“TJDztIJEANk”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]},{“lastUpdated”:“2018-10-04T11:44:34.256”,“id”:“hyNcK590UD9”,“href”:“https://dhis.medmis.org/api/dashboardItems/hyNcK590UD9”,“created”:“2018-10-04T11:44:34.256”,“type”:“EVENT_CHART”,“externalAccess”:false,“contentCount”:1,“shape”:“NORMAL”,“interpretationCount”:0,“interpretationLikeCount”:0,“favorite”:false,“access”:{“read”:true,“update”:true,“externalize”:true,“delete”:true,“write”:true,“manage”:true},“eventChart”:{“id”:“ypTKA9DJkUL”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]},{“lastUpdated”:“2018-10-04T11:50:42.938”,“id”:“Q48BIm87nI2”,“href”:“https://dhis.medmis.org/api/dashboardItems/Q48BIm87nI2”,“created”:“2018-10-04T11:44:31.965”,“type”:“CHART”,“externalAccess”:false,“contentCount”:2,“shape”:“FULL_WIDTH”,“interpretationCount”:0,“interpretationLikeCount”:0,“favorite”:false,“visualization”:{“id”:“YTGsX8kCy1D”},“access”:{“read”:true,“update”:true,“externalize”:true,“delete”:true,“write”:true,“manage”:true},“lastUpdatedBy”:{“displayName”:"Deepali Sahu”,“id”:“ijX29jM1Frv”,“username”:“dsahu”},“chart”:{“id”:“YTGsX8kCy1D”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]},{“lastUpdated”:“2018-10-04T11:44:31.230”,“id”:“hPZ6gOkkT5n”,“href”:“https://dhis.medmis.org/api/dashboardItems/hPZ6gOkkT5n",“created”:“2018-10-04T11:44:31.230”,“type”:“CHART”,“externalAccess”:false,“contentCount”:2,“shape”:“NORMAL”,“interpretationCount”:0,“interpretationLikeCount”:0,“favorite”:false,“visualization”:{“id”:“reCk1cKJGul”},“access”:{“read”:true,“update”:true,“externalize”:true,“delete”:true,“write”:true,“manage”:true},“chart”:{“id”:“reCk1cKJGul”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]},{“lastUpdated”:“2018-10-04T11:54:14.479”,“id”:“FPTMFx8cy2V”,“href”:“https://dhis.medmis.org/api/dashboardItems/FPTMFx8cy2V”,“created”:“2018-10-04T11:44:30.371”,“type”:“CHART”,“externalAccess”:false,“contentCount”:2,“shape”:“DOUBLE_WIDTH”,“interpretationCount”:0,“interpretationLikeCount”:0,“favorite”:false,“visualization”:{“id”:“PeRYo9r3PN4”},“access”:{“read”:true,“update”:true,“externalize”:true,“delete”:true,“write”:true,“manage”:true},“lastUpdatedBy”:{“displayName”:"Deepali Sahu”,“id”:“ijX29jM1Frv”,“username”:“dsahu”},“chart”:{“id”:“PeRYo9r3PN4”},“favorites”:[],“reports”:[],“translations”:[],“userGroupAccesses”:[],“attributeValues”:[],“resources”:[],“users”:[],“userAccesses”:[]}],“userAccesses”:[]}

I did and the dashboard is not there
what is this issue can you please tell
this is really weird where does dashboard goes.

Looking for your help

Just wanted to inform you we have upgraded from 2.33 to 2.35

From a brief look at the api response you have sent me, I can see that no accesses for users or userGroups are defined in the configuration of the dashboard

"publicAccess": "--------",
"externalAccess": false,
"userAccesses": [],
"userGroupAccesses": []

You need to create a user group, let’s say “test”.
Even if you are superuser, you need to add yourself and other users to that group.
Then open sharing settings for the dashboard using the following account:

"user": {
                "displayName": "Deepali Sahu",
                "id": "ijX29jM1Frv",
                "username": "dsahu"

Share this dashboard with the “test” userGroup
For testing purposes you may also enable public access for the dashboard, to check whether other users are able to access the dashboard.

Make sure to make sure that for admins should have “edit and view” rights for metadata while other user groups should just have “view” rights.

If it does not work with the selected dashboard WtJ6zv91VBj try creating a test dashboard and testing whether users can see it.

Thanks Yury it worked.

One more error i am observing when we have ugraded the system to 2.35 is the tables and charts which were already designed in 2.33 and now when we try to do any modification with any of the dimension it does not let us save the table under the existing name

But still i think there is a bug
can you please check at your end and confirm.Even Myself assigned the superuser group and the user group has been assigned to that dashbord still it says “data sharing is not enabled” and when i refresh the page then all the users and user group are unselected fromm the sharing settings and then again if we try to assign the super user thorugh sharimg setting it works fine

why this is happening?

Please keep in mind that charts in 2.33 became visualizations in 2.35.

There is a chance that you need to review the visualizations after the upgrade.

1 Like