Replicate user - unable to change basic information

I am currently trying to replicate user to add new users with same rights / roles. Therefore I always replicate the user, give a new username / password and change the details like the first name, last name, email address afterwards. It was always working - not anymore. If I change the details now and save it the old name of the replicated user is still showing up. Has anybody an idea how I can do it?

Hi @AnnikaWeber

I have used that trick many times and found it very helpful. I usually replicate (admin/district) on play.dhis2.org so I can use it without affect other players :slight_smile:

It’ll be helpful if you mention which DHIS2 version you are using? If we can reproduce this on play.dhis2.org then we can immediately create a bug issue; however, if we can’t replicate it, we will need to debug and find what the issue is.

Thanks!

Hi @Gassim

Thanks for your quick answer. It is strange as it worked for 2 years now, and suddenly not. We are using Version 2.39.5

Best
Annika

Hi
I tried reproducing the issue on play.dhis2.org 2.39.5 version and I couldn’t because I was able to replicate a user successfully.

Would you please get more information about the network request that is being sent when you replicate in your instance?


Check the response in the Network tab (DevTools F12 → Network tab)

Thanks!

The issue is not to replicate the user but afterwards to change the details of the person, e.g. on your second screenshot to change the name of John Traore to another user name (also the mail adress). Can you do these changes after replicate the user on the play instance?

I just noticed that it is not about replicated users - I also cannot do any changes in existing users, e.g. if I would like to change a user role or change the email of an existing use, data that I enter is not saved once I click on save changes.