psqlodbc driver on 64 bit windows 7 computer

I’ve just set up a new laptop and have not been able to find the correct psqlodbc driver to use with DHIS-2 running Postgres 8.4.

The only drivers that install and show up in the ODBC drivers when I create a new data source are the x64 drivers. The other drivers seem to install correctly but do not appear in the list. When I use the 64 bit driver I can’t connect with Microsoft Excel or Access 2010 – they give a message saying that the architecture is different.

Has anyone found a driver that will work?

Randy Wilson

HMIS Advisor

MOH Rwanda

Have you looked at the drivers from here: http://www.postgresql.org/ftp/odbc/versions/

postgres 8 ones have been 32-bit I think

···

Regards,
Saptarshi PURKAYASTHA

My Tech Blog: http://sunnytalkstech.blogspot.com
You Live by CHOICE, Not by CHANCE

On 8 August 2012 16:03, Wilson,Randy rwilson@msh.org wrote:

I’ve just set up a new laptop and have not been able to find the correct psqlodbc driver to use with DHIS-2 running Postgres 8.4.

The only drivers that install and show up in the ODBC drivers when I create a new data source are the x64 drivers. The other drivers seem to install correctly but do not appear in the list. When I use the 64 bit driver I can’t connect with Microsoft Excel or Access 2010 – they give a message saying that the architecture is different.

Has anyone found a driver that will work?

Randy Wilson

HMIS Advisor

MOH Rwanda


Mailing list: https://launchpad.net/~dhis2-users

Post to : dhis2-users@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-users

More help : https://help.launchpad.net/ListHelp

Hi Randy,

To setup DSN for 32-bit application you must use:
%WINDIR%\SysWOW64\odbcad32.exe

and for 64-bit application you must use:
%WINDIR%\System32\odbcad32.exe

I suspect your office is 32 bit.

Best regards,
Jason

···

On Wed, Aug 8, 2012 at 4:03 PM, Wilson,Randy <rwilson@msh.org> wrote:

I’ve just set up a new laptop and have not been able to find the correct
psqlodbc driver to use with DHIS-2 running Postgres 8.4.

The only drivers that install and show up in the ODBC drivers when I create
a new data source are the x64 drivers. The other drivers seem to install
correctly but do not appear in the list. When I use the 64 bit driver I
can’t connect with Microsoft Excel or Access 2010 – they give a message
saying that the architecture is different.

Has anyone found a driver that will work?

Randy Wilson

HMIS Advisor

MOH Rwanda

_______________________________________________
Mailing list: DHIS 2 Users in Launchpad
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : DHIS 2 Users in Launchpad
More help : ListHelp - Launchpad Help

Hi Randy,

I think the driver is probably correct, but what is really confusing
is that there are two ODBCAD32.exe files on Win 64.

You should use this one:
C:\Windows\SysWOW64\odbcad32.exe

···

On Wed, Aug 8, 2012 at 4:03 PM, Wilson,Randy <rwilson@msh.org> wrote:

I’ve just set up a new laptop and have not been able to find the correct
psqlodbc driver to use with DHIS-2 running Postgres 8.4.

The only drivers that install and show up in the ODBC drivers when I create
a new data source are the x64 drivers. The other drivers seem to install
correctly but do not appear in the list. When I use the 64 bit driver I
can’t connect with Microsoft Excel or Access 2010 – they give a message
saying that the architecture is different.

Has anyone found a driver that will work?

Randy Wilson

HMIS Advisor

MOH Rwanda

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

--
Knut Staring
Dept. of Informatics, University of Oslo
+4791880522
http://dhis2.org

Not always. It depends on whether you are connecting to the database
from a 64 bit or 32 bit client. In this case, if Office is 32 bit,
then the 32 bit drivers must be installed and configured. If you are
using 64 bit apps (like 64 bit R for instance) you will use the 64 bit
drivers, which can be configured through the respective ODBC control
panels. Both 32 bit and 64 bit connections will show up however in
both of the ODBC control panels, so it gets a bit confusing. :-/

Regards,
Jason

···

On Wed, Aug 8, 2012 at 4:09 PM, Knut Staring <knutst@gmail.com> wrote:

Hi Randy,

I think the driver is probably correct, but what is really confusing
is that there are two ODBCAD32.exe files on Win 64.

You should use this one:
C:\Windows\SysWOW64\odbcad32.exe

On Wed, Aug 8, 2012 at 4:03 PM, Wilson,Randy <rwilson@msh.org> wrote:

I’ve just set up a new laptop and have not been able to find the correct
psqlodbc driver to use with DHIS-2 running Postgres 8.4.

The only drivers that install and show up in the ODBC drivers when I create
a new data source are the x64 drivers. The other drivers seem to install
correctly but do not appear in the list. When I use the 64 bit driver I
can’t connect with Microsoft Excel or Access 2010 – they give a message
saying that the architecture is different.

Has anyone found a driver that will work?

Randy Wilson

HMIS Advisor

MOH Rwanda

_______________________________________________
Mailing list: DHIS 2 Users in Launchpad
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : DHIS 2 Users in Launchpad
More help : ListHelp - Launchpad Help

--
Knut Staring
Dept. of Informatics, University of Oslo
+4791880522
http://dhis2.org

_______________________________________________
Mailing list: DHIS 2 Users in Launchpad
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : DHIS 2 Users in Launchpad
More help : ListHelp - Launchpad Help

Thanks Jason!

Your answer did the trick.

Here is a little more information for others who are using 64 bit windows 7 computers but have 32 bit Microsoft Office 2010:

1. select Postgresql ODBC drivers through the Postgres stackbuilder or download from:

http://www.postgresql.org/ftp/odbc/versions/msi/

the 32 bit driver I used is: psqlodbc_09_01_0100.zip.

2. once the driver downloads click on the zip file to open it and run the .msi file.
3. install the driver with all the default settings.

Trap: If you now try to create a new data source (DSN) using the regular procedure: Control Panel-Administrative tools-Data sources, you will not see the 32 bit Postgres driver listed driver listed so you can't create a new data source with it.

Solution: If you run the file Jason identified:
%WINDIR%\SysWOW64\odbcad32.exe

Then the same data source creation dialog pops up, but now the 32 bid postgres driver is listed and you can create your data source as you like.

Randy Wilson

···

-----Original Message-----
From: Jason Pickering [mailto:jason.p.pickering@gmail.com]
Sent: Wednesday, August 08, 2012 4:10 PM
To: Wilson,Randy
Cc: dhis2-users@lists.launchpad.net
Subject: Re: [Dhis2-users] psqlodbc driver on 64 bit windows 7 computer

Hi Randy,

To setup DSN for 32-bit application you must use:
%WINDIR%\SysWOW64\odbcad32.exe

and for 64-bit application you must use:
%WINDIR%\System32\odbcad32.exe

I suspect your office is 32 bit.

Best regards,
Jason

On Wed, Aug 8, 2012 at 4:03 PM, Wilson,Randy <rwilson@msh.org> wrote:

I've just set up a new laptop and have not been able to find the
correct psqlodbc driver to use with DHIS-2 running Postgres 8.4.

The only drivers that install and show up in the ODBC drivers when I
create a new data source are the x64 drivers. The other drivers seem
to install correctly but do not appear in the list. When I use the 64
bit driver I can't connect with Microsoft Excel or Access 2010 - they
give a message saying that the architecture is different.

Has anyone found a driver that will work?

Randy Wilson

HMIS Advisor

MOH Rwanda

_______________________________________________
Mailing list: https://launchpad.net/~dhis2-users
Post to : dhis2-users@lists.launchpad.net
Unsubscribe : https://launchpad.net/~dhis2-users
More help : https://help.launchpad.net/ListHelp

Thanks for the useful info. Anyone feel like writing a short note on
this in the implementation guide? Sure will be useful for later.