Possible Bug in Analytic Tables [fixed]

Hello everyone, I have a project with program (tracker). We noticed that when we run the analytics the indicators that count the enrollments are not updated, this behavior is also possible to notice in the Event Reports application.

For example, I have the record below whose enrollment date is 2022-01-11. In the same image it is possible to see the date of the Diagnosis & Treatment event which is the same as the enrollment.

After inserting this record, I ran analytics for 1 year ago. And as usual, I cleared my browser cache.

After that, as you can see from the image, when the output type is enrollment, I don’t have any results, strange!!

But strangely when the output is Event I can see the patient.

This behavior is also observed when I have a program indicators that counts enrollments.

The workaround I’m currently using is to clear the analytic tables and run the analytic tables.

Tested on DHIS2 play V2.35.11
Thanks in Advance

1 Like

Hi @Gassim can you help me on this.
Thanks in Advance.

1 Like

Hi @asacur

Thank you for sharing this and it will probably help others if they ever go through this bug.

Since you are able to reproduce it on play.dhis2.org then I recommend you create a Jira bug issue. I’m also asking for support from the experts to support you on this, thank you!

@asacur , please before I ask for support; would you check if there’s any error log in the Network tab that you can share here? It’s very important to find these error logs (if they are there) for the experts to know what the issue is.

Open the Network tab right before you click on update to get to the image above. :+1:

Hi @Gassim,
Since I created the above examples using Dhis2 play now I can’t do that. I’m getting error 500 when I go to dhis tracker capture. I will try later.
Screenshot from 2022-02-17 11-52-59

Please try to use incognito. Sometimes play is not the best place to test either. It’s always recommended to use a clean local installation whenever possible and then use play as a final confirmation, but if it’s not a complicated issue and can be easily reproduced while in incognito then go ahead! :grin::+1::+1:


Hi @Gassim,
Here is the print screen of the console log, as you can see the system does not show anything abnormal.

To make it more understandable I replicated an indicator, malaria case, having changed it only to count enrollments instead of events. I am attaching the edits made.

metadata.json (2.8 KB)

When i ran the list with Event Output:

Is evident that we have an enrollments on 2022-02-18. But unfortunately when i ran with Enrollment Output nothing show up.

The workaround I’m currently using is to clear(delete) the analytic tables and run the analytic tables.

Thanks in Advance

Thanks, what about the network log please?

Yes I think that whenever you have to make changes to the Metadata you’d need to clear the browser cache as well as run the analytics tables! :+1:

So if you clear the analytics tables and then run the them again, you are able to see the new enrollments?

Hi @Gassim

But after i delete the analytic tables and run again everything work as expected.

With this in mind, since most of our program indicator use the enrollments calculation, the work around that we a using before executing the programmed analytics we execute a curl
curl --location --request POST 'https://address/api/maintenance/analyticsTablesClear

This call delete the table in question and the system crontab generate it again.


1 Like

Hi @Gassim, can you help me create a card on Jira?

Hi @asacur,

Yes, sure! I’ve asked for support and I think it might be helpful if you create a jira issue.

Thanks for asking! First you’d need to create an account in jira.dhis2.org please then go to https://jira.dhis2.org/secure/CreateIssue!default.jspa

After that click on Next, please fill out the information, add the label CoP, and for this issue I’d choose the software “Event Reports app” and the product team “platform”. It would be perfect if you add the screenshots you posted, please!

And then please post the Jira issue link in the CoP topic you created.

Thank you! :grin::+1:

Hello Again @Gassim, iam sharing the link of the issue on Jira for review and ranking.

1 Like

Thanks @asacur!

Issue has been marked as done, I also saw your comments in the issue, thanks for following up! :+1::+1::+1::+1::+1: