Options for option sets not showing up - Tracker Capture


We recently set up a new server and imported data, however, there seems to be problems with options not showing up.

I think it has to do with some configuration setting, but haven’t been to figure out yet. The program rule variables have been checked to use option code for option set.

I’ve tried creating a manual Option Set with Options and use it on a testing DE, but the options are still not loaded/visible.

1 Like

Hi @dhis2-platform team, - please help @wtum here.


I think the @dhis2-tracker team will be able to help out with this one.

1 Like

Thank you @hendrik


Hi @dhis2-tracker,

We tried importing (with the dry run) everything fresh again into a new server but still encounter the same issue. We imported in the following order:

  • Users/User Groups/Org Units etc.
  • TrackedEntityAttributes & TrackedEntityTypes
  • Options, OptionSets, DataElements
  • DataFormEntry
  • Programs/ProgramStages/ProgramStageSections/ProgramTrackedEntityAttributes

Hey @wtum,
If you also tried to create an option set manually for testing, the import is probably not the cause. Do you see any errors in the browsers console window when you open the tracker?


1 Like

Hi @Markus,

No, there isn’t any new errors that we haven’t seen before aside from these:

Out of all the option sets that are associated with Tracked Entity Attributes and/or Data Elements, only one Option appears to be visible sometimes.

I’ve also already tried clearing cache browser and opening it in incognito.
The only difference between the original server and the two new servers that we’ve been importing to is that the original one uses the older war file. All of them are using version 2.30.

1 Like